Bug 205757 - REGRESSION: [ Mac ] webgl/1.0.3/conformance/textures/texture-upload-size.html is a flaky timeout
Summary: REGRESSION: [ Mac ] webgl/1.0.3/conformance/textures/texture-upload-size.html...
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on: 207006
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-03 15:57 PST by Truitt Savell
Modified: 2020-04-28 23:26 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Truitt Savell 2020-01-03 15:57:53 PST
webgl/1.0.3/conformance/textures/texture-upload-size.html

Description:
This test is very infrequent timeout across Mac. It most frequently times out on Mac wk1

History:
https://results.webkit.org/?suite=layout-tests&test=webgl%2F1.0.3%2Fconformance%2Ftextures%2Ftexture-upload-size.html
Comment 1 Radar WebKit Bug Importer 2020-01-03 15:58:11 PST
<rdar://problem/58309347>
Comment 2 Truitt Savell 2020-01-03 16:14:36 PST
marked this test as timeout in: https://trac.webkit.org/changeset/254020/webkit
Comment 3 Alexey Proskuryakov 2020-01-03 16:26:07 PST
When did it regress, at least roughly?
Comment 4 Truitt Savell 2020-01-03 16:30:20 PST
This test has been timing out sense it was introduced in https://trac.webkit.org/changeset/252121/webkit
Comment 5 Justin Fan 2020-01-31 13:22:21 PST
Logging reveals getError() is the last method being called; it is making it down to the GraphicsContextGL call, which means the issue likely lies in the driver.

Switching to ANGLE may actually fix this (since right now it does not call the ANGLE version of glGetError). Even if it is not getError, it doesn’t appear anything is hanging at the WebKit level so it is worth revisiting this after the ANGLE switch.
Comment 6 Ryan Haddad 2020-04-28 23:26:39 PDT
Removed flaky expectation in r260879 since this test has been consistently passing for the past few weeks.