Bug 205650 - REGRESSION(r253360): [GTK] Page starts loading during animation in back/forward gesture
Summary: REGRESSION(r253360): [GTK] Page starts loading during animation in back/forwa...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-30 13:18 PST by Alexander Mikhaylenko
Modified: 2020-06-19 05:27 PDT (History)
11 users (show)

See Also:


Attachments
Patch (1.88 KB, patch)
2020-05-05 05:19 PDT, Alexander Mikhaylenko
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Mikhaylenko 2019-12-30 13:18:31 PST
This only happens in non-accelerated mode.

Looks like `DrawingAreaCoordinatedGraphics` still redraws everything in non-accelerated mode when the layer tree state is frozen.
Comment 1 Alexander Mikhaylenko 2019-12-30 13:21:32 PST
This is a regression from https://github.com/WebKit/webkit/commit/94d2fcd0c2eb2399b31253290153676de5cf21ee, as that change relies on freezing to prevent page redraws.
Comment 2 Alexander Mikhaylenko 2020-05-05 05:19:55 PDT
Created attachment 398497 [details]
Patch
Comment 3 Alexander Mikhaylenko 2020-05-05 05:20:53 PDT
I'm not sure this is a clean fix, but it works.
Comment 4 EWS 2020-06-19 05:27:28 PDT
Committed r263259: <https://trac.webkit.org/changeset/263259>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 398497 [details].