Bug 20498 - Crash on Java script
Summary: Crash on Java script
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.urbanmusicblog.net/
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-24 09:45 PDT by Jason Dillon
Modified: 2009-01-04 12:17 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Dillon 2008-08-24 09:45:04 PDT
every-time javascript engages on this site when you click on a download new music link the rotating ball appears and web-kit quits.
Comment 1 Mark Rowe (bdash) 2008-08-24 14:48:25 PDT
Please attach a crash log so that we can see more information about the crash.  See <http://webkit.org/quality/crashlogs.html> for more information about how to get a crash log.
Comment 2 Cameron Zwarich (cpst) 2008-08-24 15:31:42 PDT
I can't seem to reproduce this. Can you give more specific steps?
Comment 3 John Moe 2008-08-24 15:46:07 PDT
When I saw this and tried it I crashed repeatedly at:
http://www.zshare.net/audio/17529753dd32b2e9/

I do not anymore.  Could it have been an ad?


(I was excited, because it seemed to be the same crash I was experiencing in Bug 20480.)
Comment 4 Jason Dillon 2008-08-25 06:22:28 PDT
You must click on a link for a song, or one that is labeled new music. which will re-direct you to a separate download page. On that page when you click the green "download" button the browser will crash every time.
Comment 5 Jason Dillon 2008-08-25 06:25:01 PDT
In fact you do not even need to click on the download link, just click any link on the page that leads to music and it will open up another window/tab to a download page and crash.
Comment 6 Alexey Proskuryakov 2008-08-25 06:59:10 PDT
I cannot reproduce this by following the above steps. Yes, it is possible that this is related by a particular ad.

As Mark said, please attach a crash log.
Comment 7 Jason Dillon 2008-08-25 07:16:05 PDT
All you need to do is click a link to "read more" or "new music" an it will direct you to another page with a green download link which invokes the JS engine.
Comment 8 Robert Blaut 2009-01-04 12:17:12 PST
(In reply to comment #7)
> All you need to do is click a link to "read more" or "new music" an it will
> direct you to another page with a green download link which invokes the JS
> engine.
> 

I also cannot reproduce the reported crash bug in WebKit r39572.

Jason we need full crash log. Without it we unable to proceed with this bug report.

I have to close this bug since we are unable to reproduce it for now. 

Feel free to reopen it if you still experience crashed in the latest WebKit, but please remember to attach requested details.