Bug 20404 - Full-screen movies flicker while playing
Summary: Full-screen movies flicker while playing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://railscasts.com/episodes/archive
Keywords: InRadar
: 20411 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-15 12:57 PDT by Juan Falgueras
Modified: 2008-08-19 10:56 PDT (History)
2 users (show)

See Also:


Attachments
Patch to ignore setVisible when state is not changing. (2.36 KB, patch)
2008-08-19 10:40 PDT, Eric Carlson
adele: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Falgueras 2008-08-15 12:57:10 PDT
I've tested it the same pages with Safari and it works ok.
Comment 1 Mark Rowe (bdash) 2008-08-16 17:53:32 PDT
*** Bug 20411 has been marked as a duplicate of this bug. ***
Comment 2 Mark Rowe (bdash) 2008-08-16 17:55:00 PDT
<rdar://problem/6154695>
Comment 3 Adele Peterson 2008-08-18 11:15:08 PDT
does this happen with all videos from this page?  or one particular video?
Comment 5 Gavin Sherlock 2008-08-19 07:12:53 PDT
Testing with:

http://media.railscasts.com/videos/001_caching_with_instance_variable.mov

it regressed between r35755 and r35773.

To my untrained eye, I suspect:

http://trac.webkit.org/changeset/35772

but as I say, it's an untrained eye.

I don't have privileges to update the title and priority to reflect that it's a regression, and when it regressed.
Comment 6 Eric Carlson 2008-08-19 10:40:18 PDT
Created attachment 22877 [details]
Patch to ignore setVisible when state is not changing.
Comment 7 Adele Peterson 2008-08-19 10:56:12 PDT
Committed revision 35840.