Bug 203765 - REGRESSION(r248696): Element Click on Mac is adding an extra page topContentInsets to y-coordinate
Summary: REGRESSION(r248696): Element Click on Mac is adding an extra page topContentI...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebDriver (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brian Burg
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-11-01 14:55 PDT by Brian Burg
Modified: 2019-11-01 15:20 PDT (History)
3 users (show)

See Also:


Attachments
Patch (1.81 KB, patch)
2019-11-01 15:03 PDT, Brian Burg
drousso: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2019-11-01 14:55:08 PDT
.
Comment 1 Brian Burg 2019-11-01 14:55:22 PDT
<rdar://problem/56014369>
Comment 2 Brian Burg 2019-11-01 15:03:10 PDT
Created attachment 382635 [details]
Patch
Comment 3 Devin Rousso 2019-11-01 15:05:37 PDT
Comment on attachment 382635 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=382635&action=review

r=me, an all negative diff I love it =D

> Source/WebKit/ChangeLog:11
> +        The topContentInsets is now accounted for by rootViewToWindow(), so don't add it in manually.

Shouldn't this just be "The topContentInset is"?

Also, was this something that changed recently (the "now" makes it seem like this wasn't the case before)?  If so, do you know what revision?  If not, please remove the "now".
Comment 4 Brian Burg 2019-11-01 15:09:15 PDT
(In reply to Devin Rousso from comment #3)
> Comment on attachment 382635 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=382635&action=review
> 
> r=me, an all negative diff I love it =D
> 
> > Source/WebKit/ChangeLog:11
> > +        The topContentInsets is now accounted for by rootViewToWindow(), so don't add it in manually.
> 
> Shouldn't this just be "The topContentInset is"?

Yes.

> 
> Also, was this something that changed recently (the "now" makes it seem like
> this wasn't the case before)?  If so, do you know what revision?  If not,
> please remove the "now".

This method was reworked this spring to work in terms of viewport coordinates. I'll just drop 'now' since there were many relevant commits in this chain of regressions.
Comment 5 Brian Burg 2019-11-01 15:16:36 PDT
Committed r251948: <https://trac.webkit.org/changeset/251948>