Bug 203588 - [ Mac Debug ] (r251706) webanimations/empty-keyframes-crash.html is crashing
Summary: [ Mac Debug ] (r251706) webanimations/empty-keyframes-crash.html is crashing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
: 203641 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-29 14:38 PDT by Truitt Savell
Modified: 2019-10-30 16:25 PDT (History)
5 users (show)

See Also:


Attachments
Patch (3.19 KB, patch)
2019-10-30 03:26 PDT, Antoine Quint
dino: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Truitt Savell 2019-10-29 14:38:30 PDT
The changes in https://trac.webkit.org/changeset/251706/webkit

broke webanimations/empty-keyframes-crash.html casting it to crash on Mac debug.

History: https://results.webkit.org/?suite=layout-tests&test=webanimations%2Fempty-keyframes-crash.html

Log:

Application Specific Information:
CRASHING TEST: webanimations/empty-keyframes-crash.html

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.JavaScriptCore      	0x00000002eb1b4810 WTFCrash + 16 (Assertions.cpp:305)
1   com.apple.WebCore             	0x00000002d8006c6b WTFCrashWithInfo(int, char const*, char const*, int) + 27
2   com.apple.WebCore             	0x00000002d9d78ff8 WebCore::KeyframeEffect::setAnimatedPropertiesInStyle(WebCore::RenderStyle&, double) + 168 (KeyframeEffect.cpp:1070)
3   com.apple.WebCore             	0x00000002d9d78ce3 WebCore::KeyframeEffect::apply(WebCore::RenderStyle&) + 195 (KeyframeEffect.cpp:1029)


https://build.webkit.org/results/Apple%20High%20Sierra%20Debug%20WK2%20(Tests)/r251715%20(10173)/webanimations/empty-keyframes-crash-crash-log.txt
Comment 1 Radar WebKit Bug Importer 2019-10-29 14:39:52 PDT
<rdar://problem/56721908>
Comment 2 Radar WebKit Bug Importer 2019-10-29 14:40:06 PDT
<rdar://problem/56721919>
Comment 3 Antoine Quint 2019-10-30 03:26:46 PDT
Created attachment 382293 [details]
Patch
Comment 4 Antoine Quint 2019-10-30 11:46:10 PDT
Landed in r251789.
Comment 5 Matt Lewis 2019-10-30 16:23:39 PDT
*** Bug 203641 has been marked as a duplicate of this bug. ***