Bug 203536 - REGRESSION (r251639): TestWebKitAPI.GetDisplayMediaTest.Constraints is a flakey failure
Summary: REGRESSION (r251639): TestWebKitAPI.GetDisplayMediaTest.Constraints is a flak...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-10-28 16:17 PDT by Jonathan Bedard
Modified: 2019-10-29 10:34 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Bedard 2019-10-28 16:17:45 PDT
Seen it a few times in OpenSource, much more frequently internally: <https://results.webkit.org/?suite=api-tests&test=TestWebKitAPI.GetDisplayMediaTest.Constraints>.
Comment 1 Radar WebKit Bug Importer 2019-10-28 16:18:15 PDT
<rdar://problem/56689413>
Comment 2 Matt Lewis 2019-10-29 10:14:11 PDT
The various flakes seem to be caused by:
https://trac.webkit.org/changeset/251639/webkit
Comment 3 Truitt Savell 2019-10-29 10:30:22 PDT
Reverted r251646 for reason:

Caused flakey API failures for GetDisplayMediaTest.Constraints

Committed r251711: <https://trac.webkit.org/changeset/251711>
Comment 4 Truitt Savell 2019-10-29 10:34:28 PDT
Reverted r251639 for reason:

Caused flakey API failures for GetDisplayMediaTest.Constraints

Committed r251712: <https://trac.webkit.org/changeset/251712>