Bug 203003 - REGRESSION (r240250): Pages using smoothscroll.js can't be scrolled with trackpad
Summary: REGRESSION (r240250): Pages using smoothscroll.js can't be scrolled with trac...
Status: RESOLVED DUPLICATE of bug 207040
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-10-15 13:26 PDT by Simon Fraser (smfr)
Modified: 2020-03-20 13:25 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2019-10-15 13:26:02 PDT
r240250 broke scrolling on pages using the smoothscroll.js library:
https://cigarobsession.com
http://fn57sale.com
https://chopeshift.challenger.sg
Comment 1 Simon Fraser (smfr) 2019-10-15 13:26:28 PDT
rdar://problem/52712513
Comment 2 Simon Fraser (smfr) 2019-10-15 13:26:47 PDT
Need to see if these sites are also broken in Chrome, and if not, why not.
Comment 3 Ali Juma 2019-10-15 13:57:18 PDT
(In reply to Simon Fraser (smfr) from comment #2)
> Need to see if these sites are also broken in Chrome, and if not, why not.

This is the Chromium bug for sites with smoothscroll.js being broken by the change to document.documentElement as the viewport scroller: https://bugs.chromium.org/p/chromium/issues/detail?id=501568

It was fixed by this intervention in Blink, that targets smoothscroll.js:
https://groups.google.com/a/chromium.org/forum/#!msg/blink-dev/2iOz5-fgD8Y/GO7qLkg4BwAJ
Comment 4 Michael Catanzaro 2020-03-20 13:25:43 PDT

*** This bug has been marked as a duplicate of bug 207040 ***