Bug 20270 - REGRESSION (r35244): Cannot take Acid 2 Test
Summary: REGRESSION (r35244): Cannot take Acid 2 Test
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://acid2.acidtests.org/
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2008-08-03 20:03 PDT by BJ Homer
Modified: 2008-08-08 17:29 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BJ Homer 2008-08-03 20:03:32 PDT
Visiting http://acid2.acidtests.org/ directs the user to click a link in order to take the Acid2 test.  The link directs the user to an anchor on the same page (#top), but nothing happens.  Clicking the link in other browsers causes the page to display the famed smiley face.
Comment 1 Matt Lilek 2008-08-03 20:10:38 PDT
Dupe of or related to bug 20038?
Comment 2 David Kilzer (:ddkilzer) 2008-08-04 12:51:21 PDT
In this case there is no form submission (unlike Bug 20038).  Will investigate.

Comment 3 David Kilzer (:ddkilzer) 2008-08-05 03:51:11 PDT
The bisect-builds script reports:

Works: r35231  Fails: r35249

Comment 4 David Kilzer (:ddkilzer) 2008-08-05 04:44:13 PDT
Running git-bisect shows that this regressed in r35244.

http://trac.webkit.org/changeset/35244

Comment 5 David Kilzer (:ddkilzer) 2008-08-05 04:45:50 PDT
<rdar://problem/6125492>
Comment 6 Maxime Britto 2008-08-08 17:16:18 PDT
fixed in r35648
Comment 7 David Kilzer (:ddkilzer) 2008-08-08 17:29:36 PDT
http://trac.webkit.org/changeset/35648