Bug 202545 - Fix WebGL 1 conformance regressions when USE_ANGLE=1
Summary: Fix WebGL 1 conformance regressions when USE_ANGLE=1
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: ANGLE (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: James Darpinian
URL:
Keywords: InRadar
Depends on:
Blocks: webglangle
  Show dependency treegraph
 
Reported: 2019-10-03 15:17 PDT by James Darpinian
Modified: 2020-03-11 17:12 PDT (History)
12 users (show)

See Also:


Attachments
Fix WebGL 1 conformance regressions when USE_ANGLE=1 (6.93 KB, patch)
2019-10-03 15:19 PDT, James Darpinian
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Darpinian 2019-10-03 15:17:23 PDT
Fix WebGL 1 conformance regressions when USE_ANGLE=1
Comment 1 James Darpinian 2019-10-03 15:19:52 PDT
Created attachment 380163 [details]
Fix WebGL 1 conformance regressions when USE_ANGLE=1
Comment 2 James Darpinian 2019-10-03 15:23:33 PDT
After this patch plus a couple of upstream changes I'm working on in ANGLE, setting USE_ANGLE=1 on Mac fixes a bunch of WebGL conformance tests and causes no new test regressions.
Comment 3 WebKit Commit Bot 2019-10-03 20:48:18 PDT
Comment on attachment 380163 [details]
Fix WebGL 1 conformance regressions when USE_ANGLE=1

Clearing flags on attachment: 380163

Committed r250697: <https://trac.webkit.org/changeset/250697>
Comment 4 WebKit Commit Bot 2019-10-03 20:48:19 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Radar WebKit Bug Importer 2019-10-03 20:49:16 PDT
<rdar://problem/55972310>
Comment 6 Darin Adler 2019-10-08 09:32:04 PDT
Comment on attachment 380163 [details]
Fix WebGL 1 conformance regressions when USE_ANGLE=1

View in context: https://bugs.webkit.org/attachment.cgi?id=380163&action=review

> Source/WebCore/html/canvas/WebGLDebugShaders.cpp:54
>      if (m_context.isContextLost())
>          return String();

Since this function can no longer return null, it doesn’t make sense to return a null string here. Before the change to the bindings, this would turn into a JavaScript null, so this line of code may have had a valuable effect. We should consider returning an empty string here. Or perhaps removing this code entirely as long as the validateWebGLObject function is guaranteed to return false when the context is lost.