Bug 20167 - links in Error Console don't jump to indicated line
Summary: links in Error Console don't jump to indicated line
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Normal
Assignee: Nobody
URL: http://goo.ne.jp/
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2008-07-25 00:27 PDT by Michael[tm] Smith
Modified: 2008-09-26 19:27 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael[tm] Smith 2008-07-25 00:27:50 PDT
In my environment (running July 22 nightly with Safari), I seem to be able to observe this problem with any page that has errors.

The problem is that if I click a link in the Error Console that displays a line number in HTML page/file or other resource that has an error, it jumps to displaying the file containing the error, but does not jump me to the line that contains the error.

To reproduce:

1. Open http://goo.ne.jp/
2. Show Error Console
3. Reload http://goo.ne.jp/ .. Error console shows line with "<a> misnested or not properly closed.  Cloning <a> in order to preserve the styles applied by it. http://goo.ne.jp/ (line 401)"
4. Click on that line.
5. Web Inspector displays HTML source for http://goo.ne.jp/ but does not jump to line 401 (shows top of file instead).
Comment 1 Timothy Hatcher 2008-07-27 13:48:34 PDT
<rdar://problem/6100597>
Comment 2 Robert Blaut 2008-07-29 05:02:22 PDT
Confirmed.
Comment 3 Oliver Hunt 2008-09-26 05:22:17 PDT
This is now fixed -- could you confirm with a nightly?
Comment 4 Peter Enevoldsen 2008-09-26 05:42:10 PDT
Confirmed. Works really nice.
Comment 5 Michael[tm] Smith 2008-09-26 19:27:37 PDT
yeah, tested with nightly and works for me too -- jumps to correct line and does the yellow highlighting thing with fade-out. Very nice