Bug 20166 - CSS Perspective Transform works on iPhone but not in Safari
: CSS Perspective Transform works on iPhone but not in Safari
Status: RESOLVED FIXED
: WebKit
CSS
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-07-24 21:42 PST by
Modified: 2010-04-22 07:51 PST (History)


Attachments
css perspective transform example from Apple documentation (537 bytes, text/html)
2008-07-24 21:43 PST, CJ Yetman
no flags Details
Patch (5.18 KB, patch)
2009-07-10 21:33 PST, Simon Fraser (smfr)
oliver: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-07-24 21:42:13 PST
The CSS perspective transform, as described here

http://developer.apple.com/webapps/docs_iphone/documentation/iPhone/Conceptual/SafariCSSTransformGuide/TransformProperties/chapter_5_section_5.html

works handsomely on the new iPhone 2.0 Safari, but it does not on the current nightly WebKit (r35289), Safari 3.1.1 (5525.20), nor the Safari 4 beta (5526.11.2).

I'll attach the example provided in Apple's documentation as a test-case.
-cj
------- Comment #1 From 2008-07-24 21:43:34 PST -------
Created an attachment (id=22472) [details]
css perspective transform example from Apple documentation
------- Comment #2 From 2008-08-09 03:37:13 PST -------
Confirmed still broken in nightly r35615 binary for Windows.
------- Comment #3 From 2008-08-11 12:57:21 PST -------
None of the 3d stuff is implemented on the desktop yet.  It works only on the phone.
------- Comment #4 From 2009-01-03 19:40:42 PST -------
As hyatt said, perspective is not supported on desktop WebKit.
------- Comment #5 From 2009-01-03 20:53:04 PST -------
> As hyatt said, perspective is not supported on desktop WebKit.

It will never be supported on the desktop? Really?

May I ask why the disparity?
------- Comment #6 From 2009-01-10 07:51:25 PST -------
I request this is reopened and changed to Severity: Enhancement.
------- Comment #7 From 2009-01-10 09:37:21 PST -------
Changing to Enhancement.
------- Comment #8 From 2009-06-16 16:31:38 PST -------
Based on the information provided at WWDC09, I'd consider this a bug rather than an enhancement.  These features were demonstrated as part of Safari 4, yet it's obviously shipped without it.
------- Comment #9 From 2009-06-16 16:43:26 PST -------
The latest nightly build has 3D transform support, when run on SnowLeopard.
------- Comment #10 From 2009-06-17 02:01:45 PST -------
I request this issue is reopened again.

As per previous comments, feature is still missing on Windows and Linux versions of Safari causing a disparity between platforms.  Unless a coherent technical argument can be put forward as to why the 3d features can never be implemented on Windows and Linux platforms, this issue is either a bug or a feature request but either way should not be closed until resolved.
------- Comment #11 From 2009-06-17 08:40:34 PST -------
Please file new bugs specific to those platforms.
------- Comment #12 From 2009-06-17 08:52:12 PST -------
(In reply to comment #11)
> Please file new bugs specific to those platforms.


Should I file a bug specifically for Leopard (not Snow Leopard), considering all the PowerPC users out there are apparently being left behind?
------- Comment #13 From 2009-06-17 08:53:43 PST -------
Sure, there's no harm in doing so.
------- Comment #14 From 2009-06-17 09:01:28 PST -------
(In reply to comment #13)
> Sure, there's no harm in doing so.

Actually, I am the original reporter of this bug, and it was related to 10.5 not 10.6. I see in the OS parameter above that this is listed as 10.5. So, maybe this bug should be left open since it is related to Leopard, not Snow Leopard?
------- Comment #15 From 2009-06-25 19:02:46 PST -------
Hate to beat a dead horse, but I'm still very interested in this bug being reopened....

1 - Technically speaking, whether or not the CSS Transforms work on Snow Leopard or not is irrelevant to this bug, and therefore the bug should be left open until a fix for 10.5 is in the works or there is an announcement that there is no intention to make it work on 10.5

2 - Though I understand there may be underlining reasons why getting this to work on 10.6 may be a much different process than getting it to work on 10.5, for instance, a new QuickTime or QuickDraw API or whatever layer that is unique to 10.6. But even if that is the case, I find it very strange that the Webkit project would not be interested in making this work on all platforms for which there are Webkit ports.

As I understand it, these CSS functions may currently be Webkit specifc, but they are intended to function much like the standard CSS functions will once they are finalized. If and when those standards are finalized, will the Webkit project continue to ignore that they do not function properly on 10.5, leaving some ports of Webkit non-compliant with CSS standards? What other ports of Webkit will be deemed unnecessary to enable these CSS standards, and how will it be determined which ports are necessary to support and which are not?
------- Comment #16 From 2009-06-25 20:26:36 PST -------
We hear you, but continued comments in this bug won't have an impact on our ability to provide this on Leopard.
------- Comment #17 From 2009-06-26 05:58:57 PST -------
(In reply to comment #16)
> We hear you, but continued comments in this bug won't have an impact on our
> ability to provide this on Leopard.

A technical explanation of the problem may enable others to assist in providing the support. Is the implementation currently OS-specific? If so, surely there is a way to tie the transform ability into Leopard, if it can be done with iPhone OS 2.x.
------- Comment #18 From 2009-07-10 21:33:14 PST -------
Created an attachment (id=32607) [details]
Patch

There will be some new Leopard-specific pixel results that go along with this.
------- Comment #19 From 2009-07-10 21:45:26 PST -------
(From update of attachment 32607 [details])
r=me, are there no leopard tests that need their results updated?
------- Comment #20 From 2009-07-11 11:45:10 PST -------
http://trac.webkit.org/changeset/45754
------- Comment #21 From 2009-07-16 16:07:40 PST -------
Windows support is being tracked in Bug 27314: "3D CSS Transforms are not implemented in WebKit for Windows".
------- Comment #22 From 2010-04-21 22:32:43 PST -------
While I do recall 3D transforms working on 10.5, they are broken now.
Many of the 3d tests in the LayoutTests/transforms/3d/point-mapping , for instance, fail.
I believe this ticket should be reopened.
------- Comment #23 From 2010-04-22 07:51:34 PST -------
3D transforms on Leopard were disabled to work around a bug in QuickTime:
http://trac.webkit.org/changeset/55100