Bug 201104 - Parsing a data URL image with a fragment identifier at the end results a broken image
Summary: Parsing a data URL image with a fragment identifier at the end results a brok...
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 200143
  Show dependency treegraph
 
Reported: 2019-08-23 16:41 PDT by Said Abou-Hallawa
Modified: 2022-10-21 16:31 PDT (History)
4 users (show)

See Also:


Attachments
test case (355 bytes, image/svg+xml)
2019-08-23 16:41 PDT, Said Abou-Hallawa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Said Abou-Hallawa 2019-08-23 16:41:22 PDT
Created attachment 377179 [details]
test case

Open the attached test case.

Result: The SVG shows a broken image.
Expected: A 100x100 green rectangle.

The SVG has an image which has href="data:image/svg+xml<svg>...<view id='view'/>...</svg>#view". Parsing this URL fails and the image loader marks the image a "broken image".
Comment 2 Alex Christensen 2019-08-26 11:06:28 PDT
It looks like something special needs to be done when loading an SVN data url with a fragment:
https://svgwg.org/svg2-draft/linking.html#LinksIntoSVG
Comment 3 Ahmad Saleem 2022-10-21 16:31:21 PDT
Safari Technology Preview 156 passes following WPT test mentioned in Comment 01 and also the attached test case show "green" square similar to Chrome Canary 109 and Firefox Nightly 108. Marking this as "RESOLVED CONFIGURATION CHANGED". Thanks!

Please reopen if this is reproducible with other test case. Thanks!