Bug 201026 - [WebAssembly] Unhandled Promise Rejection: RangeError: Maximum call stack size exceeded.
Summary: [WebAssembly] Unhandled Promise Rejection: RangeError: Maximum call stack siz...
Status: RESOLVED DUPLICATE of bug 206436
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebAssembly (show other bugs)
Version: Safari 12
Hardware: iPhone / iPad iOS 12
: P2 Blocker
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-08-21 22:19 PDT by Kenneth Pouncey
Modified: 2020-01-17 13:01 PST (History)
9 users (show)

See Also:


Attachments
Shows the error that is sent to the console (57.65 KB, image/png)
2019-08-21 22:19 PDT, Kenneth Pouncey
no flags Details
Showing debug console with breakpoint (140.96 KB, image/png)
2019-08-21 22:20 PDT, Kenneth Pouncey
no flags Details
Success screen after Web Inspector completes all break points. (56.17 KB, image/png)
2019-08-21 22:21 PDT, Kenneth Pouncey
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Pouncey 2019-08-21 22:19:51 PDT
Created attachment 376985 [details]
Shows the error that is sent to the console

The error `Unhandled Promise Rejection: RangeError: Maximum call stack size exceeded.` is being thrown in applications using WebAssembly on mobile safari.

Example website:  https://ioese.azurewebsites.net/

This works on all major desktop browsers including safari desktop as well as android chrome.

It can be random because sometimes the site does shows up.

One way to actually get the site to load is to attach the iPhone to Web Inspector and place a break point on the first line of `blazor.webassembly.js` and reload the site.  After continuing 11 times or until the site loads.

Also reports show that adding a set timeout of about 4 seconds will allow the site to load correctly so work can continue.

See screen shots attached.

Is there a way to control the stack limit in mobile safari via a parameter to extend the call stack limit in mobile safari?

This is also affecting IOS beta 13 users as well but in all applications that used to work in iOS 12.  I will open another bug report for that.

Please let me know if this is not the place to file these incidents.
Comment 1 Kenneth Pouncey 2019-08-21 22:20:56 PDT
Created attachment 376986 [details]
Showing debug console with breakpoint
Comment 2 Kenneth Pouncey 2019-08-21 22:21:48 PDT
Created attachment 376987 [details]
Success screen after Web Inspector completes all break points.
Comment 3 Radar WebKit Bug Importer 2019-08-22 14:13:21 PDT
<rdar://problem/54613804>
Comment 4 Saam Barati 2020-01-17 13:01:59 PST

*** This bug has been marked as a duplicate of bug 206436 ***