Bug 20102 - Parser bug: malformed p {color: red !important fail;} declaration should be ignored
Summary: Parser bug: malformed p {color: red !important fail;} declaration should be i...
Status: RESOLVED DUPLICATE of bug 14346
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://hixie.ch/tests/adhoc/css/parsi...
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2008-07-18 14:38 PDT by Robert Blaut
Modified: 2008-07-18 14:57 PDT (History)
0 users

See Also:


Attachments
minimal test case (332 bytes, text/html)
2008-07-18 14:40 PDT, Robert Blaut
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Blaut 2008-07-18 14:38:26 PDT
p {color: red !important fail;} its incorrect according CSS 2.1 and should be ignored by CSS parser. Unfortunately WebKit fails in this case.

It's interesting since CSSGrammar.cpp already has such code:

  case 182:
#line 1142 "WebCore/css/CSSGrammar.y"
    {
        /* When we encounter something like p {color: red !important fail;} we should drop the declaration */
        (yyval.boolean) = false;
    ;}
    break;

but apparently something is broken.
Comment 1 Robert Blaut 2008-07-18 14:40:20 PDT
Created attachment 22376 [details]
minimal test case
Comment 2 Robert Blaut 2008-07-18 14:57:07 PDT
Ups :( It will be fixed when patch for bug 14346 will be landed.

*** This bug has been marked as a duplicate of 14346 ***