Bug 20100 - High CPU usage after using -webkit-transition
Summary: High CPU usage after using -webkit-transition
Status: RESOLVED DUPLICATE of bug 23177
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Chris Marrin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-18 14:30 PDT by David Smith
Modified: 2009-01-08 15:17 PST (History)
3 users (show)

See Also:


Attachments
reduced testcase formerly on remote site (2.29 MB, text/html)
2008-12-06 14:00 PST, mathuaerknedam
no flags Details
Somewhat smaller testcase (1.13 MB, text/html)
2009-01-03 19:24 PST, Simon Fraser (smfr)
no flags Details
Shark trace (709.41 KB, application/octet-stream)
2009-01-03 19:25 PST, Simon Fraser (smfr)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Smith 2008-07-18 14:30:40 PDT
Hover over the text and move the mouse around a bit, then move it off the window so that no more transitions are happening. Note that the CPU usage doesn't go back down.
Comment 1 mathuaerknedam 2008-12-06 14:00:48 PST
Created attachment 25822 [details]
reduced testcase formerly on remote site

This test case uses javascript and is huge just to make it easier to see the bug. The bug is still there without it, but the increase in load may be difficult to spot (depending on the system it's running on). FWIW, the reduced test case is fairly close to the real situation in which this was discovered.
Comment 2 Simon Fraser (smfr) 2009-01-03 19:24:16 PST
Created attachment 26402 [details]
Somewhat smaller testcase
Comment 3 Simon Fraser (smfr) 2009-01-03 19:25:28 PST
Created attachment 26403 [details]
Shark trace

The Shark trace show that almost all the time is in AnimationController code. There's a lot of animation thrash going on here.
Comment 4 Chris Marrin 2009-01-08 15:17:49 PST
This is not a case of "0 duration animation" as in the bug it is duped on. But the animation time is very short (0.15s) and there are tons of animations firing at once. So it takes longer than the duration to process them all, and it was hitting the same case where the animation time stopped updating before the animation finished. All fixed now.



*** This bug has been marked as a duplicate of 23177 ***