Bug 20089 - queryCommandState('underline') returns false if the selected text is also bold and italic
Summary: queryCommandState('underline') returns false if the selected text is also bol...
Status: RESOLVED DUPLICATE of bug 11022
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar
Depends on:
Blocks:
 
Reported: 2008-07-17 17:20 PDT by Joshua Peek
Modified: 2009-02-17 16:16 PST (History)
0 users

See Also:


Attachments
Demonstrations the underline state bug (682 bytes, text/html)
2008-07-17 17:23 PDT, Joshua Peek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Peek 2008-07-17 17:20:36 PDT
If you apply bold, underline, and italic styles to an element, queryCommandState will incorrectly report that the selected text is not underlined.

queryCommandState works fine under all the other combinations of bold, underline, and italic text.
Comment 1 Joshua Peek 2008-07-17 17:23:12 PDT
Created attachment 22355 [details]
Demonstrations the underline state bug

Select some text in the edit area and click "Query selected state". Notice that the underline state is false.
Comment 2 Mark Rowe (bdash) 2008-07-17 20:12:07 PDT
<rdar://problem/6085306>
Comment 3 Justin Garcia 2009-02-17 16:16:52 PST

*** This bug has been marked as a duplicate of 11022 ***