Bug 20084 - REGRESSION: Focus ring being shown on some html table cells
Summary: REGRESSION: Focus ring being shown on some html table cells
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tables (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2008-07-17 11:50 PDT by Manuel Deschamps
Modified: 2008-09-03 23:18 PDT (History)
2 users (show)

See Also:


Attachments
Yahoo Mail Table Cells (24.47 KB, image/png)
2008-07-17 11:51 PDT, Manuel Deschamps
no flags Details
NetFlix movie rates (9.78 KB, image/png)
2008-07-17 11:52 PDT, Manuel Deschamps
no flags Details
Yahoo Mail Options (15.09 KB, image/png)
2008-07-17 11:54 PDT, Manuel Deschamps
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Deschamps 2008-07-17 11:50:09 PDT
I have seen this problem in Yahoo! Mail and Netflix.

When clicking on some elements (in case of Yahoo Mail they are table cells) the focus ring is shown. This behavior did not exist on Safari 3.1

I am attaching a couple of screenshots where I have seen this problem.
Comment 1 Manuel Deschamps 2008-07-17 11:51:19 PDT
Created attachment 22345 [details]
Yahoo Mail Table Cells
Comment 2 Manuel Deschamps 2008-07-17 11:52:28 PDT
Created attachment 22346 [details]
NetFlix movie rates
Comment 3 Manuel Deschamps 2008-07-17 11:54:42 PDT
Created attachment 22348 [details]
Yahoo Mail Options
Comment 4 Justin Garcia 2008-07-17 11:57:59 PDT
<rdar://problem/6083514> REGRESSION: Focus ring being shown on some html table cells
Comment 5 Adele Peterson 2008-07-17 18:39:11 PDT
could have something to do with allowing tabindex on all elements, which makes those elements focusable
Comment 6 Manuel Deschamps 2008-07-18 12:51:11 PDT
Hi Adele,

I was looking at the places where I see the ring in Yahoo Mail, and Netlflix and all of them have tabIndexes,  although the cells in Ymail's inbox have tabindex="-1"
Comment 7 Alice Liu 2008-09-03 23:18:06 PDT
Actually this is not a regression, but rather an implementation of a new feature.  Starting in HTML5, all elements are focusable in some manner when the tabindex attribute is set.  More specifically, if an element's tabindex attribute is set to any valid integer value, that element is focusable by mouse clicks or by javascript.  If the tabindex is a value of 0 or greater, then the element also focusable (in tab order) by key events.  

Using the inspector, the yahoo mail message fields are focusable because they are table cells with tabindex=-1. 

I haven't looked into the other 2 cases, but i suspect they are similarly behaving correctly.  please inform me if i'm wrong.