Bug 200686 - REGRESSION (iPad OS 13 beta): Non-trivially sized wasm applications crash Safari
Summary: REGRESSION (iPad OS 13 beta): Non-trivially sized wasm applications crash Safari
Status: RESOLVED DUPLICATE of bug 200807
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebAssembly (show other bugs)
Version: Other
Hardware: iPhone / iPad Other
: P2 Blocker
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-08-13 13:04 PDT by Walter Stumpf
Modified: 2019-09-03 20:40 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Stumpf 2019-08-13 13:04:00 PDT
Essentially a regression on the partial fix for https://bugs.webkit.org/show_bug.cgi?id=181723 (Unhandled Promise Rejection: Error: Out of executable memory in function at index)

To reproduce with any beta of iPad OS 13:
1) Navigate with Safari to https://simulations.kognito.com/changetalk/dev
2) Notice the compiler crash immediately when attempting to load

For clarity, iOS 12.2, 12.3, 12.4 all function correctly.  Any version *before* 12.2 will result in the same error that currently happens in iPad OS 13.  Let me know if there's any other information or test case you need from me.
Comment 1 Radar WebKit Bug Importer 2019-08-13 14:55:15 PDT
<rdar://problem/54275409>
Comment 2 Walter Stumpf 2019-08-23 21:41:16 PDT
Hello,

Just wanted to add that I got around to installing iOS 13 beta (version 8) on my iPhone X and the regression exists there too.  I'm sure not too surprising, but just thought I'd share for clarity's sake.
Comment 3 Saam Barati 2019-08-27 08:25:31 PDT
Thanks for letting us know. We’re actively working on making JSC use less executable memory for Wasm in ToT WebKit.
Comment 4 Alexey Proskuryakov 2019-09-03 20:40:44 PDT
This issue should be fixed via bug 200807, sorry for the forward dupe.

*** This bug has been marked as a duplicate of bug 200807 ***