Bug 200677 - REGRESSION (r248533): JSC Command - Need to initializeMainThread() before processing config file
Summary: REGRESSION (r248533): JSC Command - Need to initializeMainThread() before pro...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 200678 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-13 11:08 PDT by Michael Saboff
Modified: 2019-08-13 12:36 PDT (History)
8 users (show)

See Also:


Attachments
Patch (1.62 KB, patch)
2019-08-13 11:16 PDT, Michael Saboff
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Saboff 2019-08-13 11:08:33 PDT
With the threading assertions added in r248533, we need to initialize threading before we process the optional config file since the config file code uses ref counted CString's and CStringBuffer's.
Comment 1 Michael Saboff 2019-08-13 11:16:11 PDT
Created attachment 376183 [details]
Patch
Comment 2 Mark Lam 2019-08-13 11:18:03 PDT
Comment on attachment 376183 [details]
Patch

r=me
Comment 3 Chris Dumez 2019-08-13 12:01:32 PDT
*** Bug 200678 has been marked as a duplicate of this bug. ***
Comment 4 WebKit Commit Bot 2019-08-13 12:35:07 PDT
Comment on attachment 376183 [details]
Patch

Clearing flags on attachment: 376183

Committed r248605: <https://trac.webkit.org/changeset/248605>
Comment 5 WebKit Commit Bot 2019-08-13 12:35:08 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Radar WebKit Bug Importer 2019-08-13 12:36:16 PDT
<rdar://problem/54269234>