Bug 200676 - Web Inspector: Elements: Styles: selectors with media queries and icons shift vertically when being edited
Summary: Web Inspector: Elements: Styles: selectors with media queries and icons shift...
Status: RESOLVED DUPLICATE of bug 200419
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-13 09:23 PDT by Devin Rousso
Modified: 2019-08-13 09:28 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2019-08-13 09:23:37 PDT
# STEPS TO REPRODUCE:
1. inspect any page with media queries
2. find a rule with a media query in Styles sidebar of the Elements Tab
3. start editing the selector
 => selector (and everything after it) shifts vertically
4. click outside the selector to stop editing
 => selector (and everything after it) shifts back to original position
Comment 1 Devin Rousso 2019-08-13 09:28:07 PDT
I noticed this while testing <https://webkit.org/b/200419>.  It looks like there was a rule (`.spreadsheet-css-declaration .header-groupings + .header > .selector > .icon`) which removed the `margin-top`.  I will remove it from that patch.

*** This bug has been marked as a duplicate of bug 200419 ***