Bug 200575 - [GTK] Video playback has striding problems with accelerated compositing
Summary: [GTK] Video playback has striding problems with accelerated compositing
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 192523
  Show dependency treegraph
 
Reported: 2019-08-09 08:11 PDT by Alexander Mikhaylenko
Modified: 2019-09-17 12:52 PDT (History)
5 users (show)

See Also:


Attachments
YouTube (1.51 MB, image/png)
2019-08-09 08:11 PDT, Alexander Mikhaylenko
no flags Details
W3Schools sample (267.34 KB, image/png)
2019-08-09 08:12 PDT, Alexander Mikhaylenko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Mikhaylenko 2019-08-09 08:11:45 PDT
Created attachment 375921 [details]
YouTube

WebKitGTK 2.25.4, Epiphany Technology Preview 3.33.90-11-g5b003a7bc - the latest available as of today.

See screenshots
Comment 1 Alexander Mikhaylenko 2019-08-09 08:12:07 PDT
Created attachment 375922 [details]
W3Schools sample
Comment 2 Xabier Rodríguez Calvar 2019-08-09 08:58:04 PDT
We're missing the stride somewhere.
Comment 3 Philippe Normand 2019-08-09 09:26:05 PDT
Works fine here. What's your GPU, graphics driver and kernel versions?
Comment 4 Alexander Mikhaylenko 2019-08-09 10:56:19 PDT
Intel UHD Graphics 620 (Kabylake GT2), Intel driver, kernel 5.2.5 (5.2.5-200.fc30.x86_64)
Comment 5 Alexander Mikhaylenko 2019-08-09 12:23:18 PDT
Also, this is Wayland session.
Comment 6 Michael Catanzaro 2019-09-17 07:19:41 PDT
Currently this is the only known issue blocking Epiphany from reenabling AC mode.
Comment 7 Philippe Normand 2019-09-17 09:14:38 PDT
Doesn't happen here on my Intel® UHD Graphics 630 (Coffeelake 3x8 GT2). 3.34.0-21-ge952d21c5 WebKitGTK 2.26.0. Kernel 4.19.0-5-amd64 on Debian Testing.

Why was gst-vaapi removed from the runtime btw? On Intel I suppose it currently works a bit better than on AMD.

Why do you consider this "issue blocking Epiphany from reenabling AC mode"?
Comment 8 Michael Catanzaro 2019-09-17 11:31:49 PDT
> Why do you consider this "issue blocking Epiphany from reenabling AC mode"?

I had tried reenabling AC mode in Epiphany about a month before Exalm reported this bug, because all the previous AC mode bugs had been resolved or closed. But then Exalm discovered that it broke YouTube for him, so I switched it back to disabled. (I hope it goes without saying that Epiphany is not going to turn AC mode back on if it breaks YouTube for anyone, let alone a prominent developer like Exalm.) So this bug is the reason it's still disabled in 3.34. We had two other bugs recently too, but Carlos Garcia solved them both today, so this is the last one.

Having a hardware blacklist/whitelist might be really helpful for "resolving" these without needing to disable AC mode for all users each time there's a problem with particular hardware.

BTW, at the time this bug was reported, we still had gstreamer-vaapi in the runtime, so it could be relevant here too. (Exalm, could you check?)

(In reply to Philippe Normand from comment #7) 
> Why was gst-vaapi removed from the runtime btw? On Intel I suppose it
> currently works a bit better than on AMD.

After talking to Sebastian, he seemed concerned about Intel too, so we agreed that it needs to be an opt-in extension that users manually install. That was a Friday and, by coincidence, we learned that the plan was to release 19.08 SDK over the weekend, so we had an unfortunate scramble to remove gst-vaapi without time to discuss widely or wait for next business day. :( freedesktop-sdk has become really strict about ABI and we would have been stuck with it for the next year otherwise.

Anyway, it will be restored soon, but as an opt-in extension that is no longer installed automatically. In the future, that situation could be reconsidered if consensus changes in the GStreamer community.
Comment 9 Alexander Mikhaylenko 2019-09-17 12:01:40 PDT
Seems to be fixed, yes (WEBKIT_FORCE_COMPOSITING_MODE=1, 2.26.0, 3.34.0-21-ge952d21c5)
Comment 10 Michael Catanzaro 2019-09-17 12:52:31 PDT
Awesome! I'll try reenabling AC mode for Ephy 3.36, then.

If you can reproduce outside flatpak, it might well have been caused by gstreamer-vaapi I would assume; I'm sure they would appreciate a bug report if so.