Bug 200442 - Setting the 'orientType' attribute of SVGMarkerElement to 'auto' should set the 'orientAngle' to '0'
Summary: Setting the 'orientType' attribute of SVGMarkerElement to 'auto' should set t...
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 200143
  Show dependency treegraph
 
Reported: 2019-08-05 11:30 PDT by Said Abou-Hallawa
Modified: 2022-08-02 09:24 PDT (History)
7 users (show)

See Also:


Attachments
test case (806 bytes, text/html)
2019-08-05 11:30 PDT, Said Abou-Hallawa
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Said Abou-Hallawa 2019-08-05 11:30:03 PDT
Created attachment 375539 [details]
test case

Open the attached test case.

Expected: No alert messages fires
Result: A message fires saying: "expected 0 but got 20"

When setting the 'orientType' attribute of SVGMarkerElement to 'auto', it is expected also to set the 'orientAngle' attribute to '0'. 'orientType' and 'orientAngle' are paired attributes.
Comment 1 Ahmad Saleem 2022-08-02 09:22:01 PDT
I am unable to reproduce this bug in Safari 15.6 on macOS 12.5 and it does not show any dialog when loading and it is matching with other browsers (Firefox Nightly 105 and Chrome Canary 106) and they also don't show any dialog box mentioned in Comment 0.

I think it was fixed along the way and this can be marked as "RESOLVED CONFIGURATION CHANGED". Thanks!
Comment 2 Ryosuke Niwa 2022-08-02 09:24:13 PDT
This is working now.