Bug 200044 - [iOS] Tapping the search field on a search results page on zillow.com shows and immediately dismisses the keyboard
Summary: [iOS] Tapping the search field on a search results page on zillow.com shows a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-07-23 13:05 PDT by zalan
Modified: 2019-07-23 14:49 PDT (History)
2 users (show)

See Also:


Attachments
Patch (9.44 KB, patch)
2019-07-23 13:20 PDT, zalan
no flags Details | Formatted Diff | Diff
Patch (9.44 KB, patch)
2019-07-23 13:57 PDT, zalan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description zalan 2019-07-23 13:05:42 PDT
<rdar://problem/53103732>
Comment 1 zalan 2019-07-23 13:20:30 PDT
Created attachment 374702 [details]
Patch
Comment 2 Wenson Hsieh 2019-07-23 13:23:11 PDT
Comment on attachment 374702 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=374702&action=review

> Source/WebCore/ChangeLog:13
> +        It works with shipping version of iOS because _zoomToFocusRect operates on stale viewport information -which has progressed with r244494.

Nit - not sure if the “-which” was intended.
Comment 3 zalan 2019-07-23 13:29:55 PDT
(In reply to Wenson Hsieh from comment #2)
> Comment on attachment 374702 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=374702&action=review
> 
> > Source/WebCore/ChangeLog:13
> > +        It works with shipping version of iOS because _zoomToFocusRect operates on stale viewport information -which has progressed with r244494.
> 
> Nit - not sure if the “-which” was intended.

oh right.
Comment 4 zalan 2019-07-23 13:57:30 PDT
Created attachment 374706 [details]
Patch
Comment 5 WebKit Commit Bot 2019-07-23 14:49:07 PDT
Comment on attachment 374706 [details]
Patch

Clearing flags on attachment: 374706

Committed r247746: <https://trac.webkit.org/changeset/247746>
Comment 6 WebKit Commit Bot 2019-07-23 14:49:08 PDT
All reviewed patches have been landed.  Closing bug.