Bug 199875 - Rebase fast/forms/ios/delete-in-input-in-iframe.html after r244141
Summary: Rebase fast/forms/ios/delete-in-input-in-iframe.html after r244141
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alex Christensen
URL:
Keywords: InRadar
: 199920 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-17 12:20 PDT by Alex Christensen
Modified: 2019-07-19 09:56 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.54 KB, patch)
2019-07-17 12:21 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (2.76 KB, patch)
2019-07-17 13:26 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (2.79 KB, patch)
2019-07-18 11:27 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff
Patch (2.32 KB, patch)
2019-07-18 15:43 PDT, Alex Christensen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2019-07-17 12:20:37 PDT
Revert part of r244141
Comment 1 Alex Christensen 2019-07-17 12:21:48 PDT
Created attachment 374313 [details]
Patch
Comment 2 Alex Christensen 2019-07-17 12:35:39 PDT
rdar://problem/50060561
Comment 3 Tim Horton 2019-07-17 12:46:18 PDT
Comment on attachment 374313 [details]
Patch

This needs a changelog with a minimum of 500 words.
Comment 4 Alex Christensen 2019-07-17 13:26:49 PDT
Created attachment 374322 [details]
Patch
Comment 5 Tim Horton 2019-07-17 13:29:08 PDT
Comment on attachment 374322 [details]
Patch

This is a so much better change
Comment 6 Megan Gardner 2019-07-18 11:10:49 PDT
Comment on attachment 374322 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=374322&action=review

Yes, much, much better, thanks for looking into this!

> LayoutTests/ChangeLog:5
> +

Radar?
Comment 7 Megan Gardner 2019-07-18 11:11:43 PDT
Comment on attachment 374322 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=374322&action=review

> LayoutTests/fast/forms/ios/delete-in-input-in-iframe-expected.txt:3
> +PASS: page scrolled to 1143

Do we want to consider just testing to see if the page scrolled at all, rather than to a specific number? This seems prone to regressions still.
Comment 8 Alex Christensen 2019-07-18 11:23:58 PDT
Comment on attachment 374322 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=374322&action=review

>> LayoutTests/fast/forms/ios/delete-in-input-in-iframe-expected.txt:3
>> +PASS: page scrolled to 1143
> 
> Do we want to consider just testing to see if the page scrolled at all, rather than to a specific number? This seems prone to regressions still.

I thought this was better so we can verify that it scrolled the expected amount.  If this becomes flaky or we change the scrolling amount too much we can change the results later
Comment 9 Alex Christensen 2019-07-18 11:27:30 PDT
Created attachment 374398 [details]
Patch
Comment 10 WebKit Commit Bot 2019-07-18 12:06:41 PDT
Comment on attachment 374398 [details]
Patch

Clearing flags on attachment: 374398

Committed r247571: <https://trac.webkit.org/changeset/247571>
Comment 11 WebKit Commit Bot 2019-07-18 12:06:43 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 Alex Christensen 2019-07-18 15:42:09 PDT
*** Bug 199920 has been marked as a duplicate of this bug. ***
Comment 13 Alex Christensen 2019-07-18 15:43:01 PDT
Reopening to attach new patch.
Comment 14 Alex Christensen 2019-07-18 15:43:02 PDT
Created attachment 374422 [details]
Patch
Comment 15 WebKit Commit Bot 2019-07-19 09:56:06 PDT
Comment on attachment 374422 [details]
Patch

Clearing flags on attachment: 374422

Committed r247648: <https://trac.webkit.org/changeset/247648>
Comment 16 WebKit Commit Bot 2019-07-19 09:56:07 PDT
All reviewed patches have been landed.  Closing bug.