Bug 19924 - Disabled file input element updates its displayed file info when a file is dropped from the Finder.
Summary: Disabled file input element updates its displayed file info when a file is dr...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P3 Minor
Assignee: Nobody
URL:
Keywords: HasReduction, InRadar
Depends on:
Blocks:
 
Reported: 2008-07-07 07:25 PDT by Matt Cooper
Modified: 2008-07-09 09:51 PDT (History)
0 users

See Also:


Attachments
Test case mentioned in original bug details. (818 bytes, text/html)
2008-07-07 07:26 PDT, Matt Cooper
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Cooper 2008-07-07 07:25:12 PDT
Summary:
Disabled file input element updates its displayed file info when a file is dropped from the Finder.

Steps to Reproduce:
1. Make a page with an input type="file" and disabled (I will attach one to this bug).
2. From the Finder, drag a file and drop it on the disabled input file element.
3. Notice that the element now displays the name of the dropped file when it shouldn't have changed at all since it is disabled.

Expected Results:
Nothing should have changed; the input file element should look the same as it did before the drag and drop.

Actual Results:
The element displays the icon and name of the dropped file.
Comment 1 Matt Cooper 2008-07-07 07:26:21 PDT
Created attachment 22131 [details]
Test case mentioned in original bug details.
Comment 2 Mark Rowe (bdash) 2008-07-07 08:29:58 PDT
<rdar://problem/6057160>
Comment 3 Adele Peterson 2008-07-07 18:14:09 PDT
Committed revision 35052.
Comment 4 Matt Cooper 2008-07-09 09:51:41 PDT
Thank you, verified as fixed in today's WebKit nightly build (AppleWebKit/527+):
r35067.dmg">http://builds.nightly.webkit.org/files/trunk/mac/WebKit-SVN-r35067.dmg