Bug 199047 - Web Inspector: current call frame indicator not visible in dark mode
Summary: Web Inspector: current call frame indicator not visible in dark mode
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-06-19 18:06 PDT by Matt Baker
Modified: 2019-07-05 14:49 PDT (History)
5 users (show)

See Also:


Attachments
[Image] Invisible current call frame indicator (599.46 KB, image/png)
2019-06-19 18:06 PDT, Matt Baker
no flags Details
Patch (2.30 KB, patch)
2019-06-19 18:11 PDT, Matt Baker
no flags Details | Formatted Diff | Diff
Patch (2.62 KB, patch)
2019-06-20 10:39 PDT, Matt Baker
no flags Details | Formatted Diff | Diff
Patch (1.94 KB, patch)
2019-07-05 13:59 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
[Image] After Patch is applied (141.35 KB, image/png)
2019-07-05 14:05 PDT, Devin Rousso
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Baker 2019-06-19 18:06:29 PDT
Created attachment 372507 [details]
[Image] Invisible current call frame indicator

This is only a problem when the call stack TreeOutline doesn't have the focus.
Comment 1 Radar WebKit Bug Importer 2019-06-19 18:07:00 PDT
<rdar://problem/51922895>
Comment 2 Matt Baker 2019-06-19 18:11:20 PDT
Created attachment 372508 [details]
Patch
Comment 3 Devin Rousso 2019-06-19 18:19:15 PDT
Comment on attachment 372508 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=372508&action=review

> Source/WebInspectorUI/UserInterface/Views/CallFrameTreeElement.css:58
> +    display: none;
> +}
> +
> +.tree-outline .item.call-frame.selected .status > .status-image {
> +    display: inline-block;

Why is this necessary?  I'm always cautious of changing `display` because it can have more far reaching implications than most other properties.
Comment 4 Matt Baker 2019-06-20 10:39:15 PDT
Created attachment 372567 [details]
Patch
Comment 5 Devin Rousso 2019-06-20 11:22:06 PDT
Comment on attachment 372567 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=372567&action=review

r-

> Source/WebInspectorUI/UserInterface/Views/CallFrameTreeElement.css:58
> +    display: none;

This cause the current call frame icon to disappear when changing call frames across an async boundary.

# STEPS TO REPRODUCE:
1. inspect <https://webkit.org>
2. set a breakpoint on the first line inside `enableScrollableTables`
3. refresh the page
 => debugger should pause on the breakpoint set in step 2
4. change call frames to the one before `--- addEvent Listener ---` (should be `Global Code`)
 => the |> on the `enableScrollableTables` call frame disappears

> Source/WebInspectorUI/UserInterface/Views/CallFrameTreeElement.css:107
> +        fill: var(--selected-foreground-color);

I think this is too bright, especially when compared to the "selected but not focused" background color.

We should create a version of `.tree-outline:focus .item.call-frame.selected .status > .status-image` inside a `@media (prefers-color-scheme: dark)`.
Comment 6 Devin Rousso 2019-06-25 10:59:55 PDT
Comment on attachment 372567 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=372567&action=review

> Source/WebInspectorUI/UserInterface/Views/CallFrameTreeElement.css:51
> +.tree-outline .item.call-frame.selected .status > .status-image {

This causes the current call frame icon to be warped when a different frame is selected.  Same steps to reproduce as below.
Comment 7 Devin Rousso 2019-07-05 13:59:25 PDT
Created attachment 373532 [details]
Patch
Comment 8 Devin Rousso 2019-07-05 14:05:03 PDT
Created attachment 373535 [details]
[Image] After Patch is applied
Comment 9 WebKit Commit Bot 2019-07-05 14:49:01 PDT
Comment on attachment 373532 [details]
Patch

Clearing flags on attachment: 373532

Committed r247179: <https://trac.webkit.org/changeset/247179>
Comment 10 WebKit Commit Bot 2019-07-05 14:49:03 PDT
All reviewed patches have been landed.  Closing bug.