Bug 19895 - Release tags are way out of date
Summary: Release tags are way out of date
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P4 Enhancement
Assignee: Nobody
URL: http://trac.webkit.org/browser/releas...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-04 07:39 PDT by opendarwin
Modified: 2009-02-25 06:49 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description opendarwin 2008-07-04 07:39:19 PDT
The Leopard release tags haven't been updated in 4 months, and the Tiger release tags haven't been updated in 7 months. In the meantime, there have been a number of releases on the Mac platform with WebKit updates.

I'm putting this as a P1 blocker because it's blocking development and testing. We have to provide support and diagnose problems for users running the latest Mac OS releases. In addition, regression testing of WebKit from public releases is impossible without the tags.

Updating the tags should be done at pretty much the same time as the release as part of a product release checklist, not something that's done randomly when someone remembers or when some user bugs you about it.
Comment 1 opendarwin 2009-02-24 14:52:38 PST
It seems that releases are getting tagged again. Indeed, Safari 4 public preview has already been tagged after being released this morning. Thus, I consider this matter resolved for now.
Comment 2 Alexey Proskuryakov 2009-02-25 06:49:09 PST
Marking as such.