Bug 198891 - [LFC][IFC] Intruding float may prevent adding any inline box
Summary: [LFC][IFC] Intruding float may prevent adding any inline box
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-06-15 14:35 PDT by zalan
Modified: 2019-06-16 13:19 PDT (History)
5 users (show)

See Also:


Attachments
Patch (12.63 KB, patch)
2019-06-15 14:40 PDT, zalan
koivisto: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description zalan 2019-06-15 14:35:13 PDT
ssia
Comment 1 Radar WebKit Bug Importer 2019-06-15 14:35:34 PDT
<rdar://problem/51779956>
Comment 2 zalan 2019-06-15 14:40:37 PDT
Created attachment 372199 [details]
Patch
Comment 3 Antti Koivisto 2019-06-16 12:09:27 PDT
Comment on attachment 372199 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=372199&action=review

> Source/WebCore/layout/LayoutUnits.h:62
> +    static Point max() { return Point(LayoutUnit::max(), LayoutUnit::max()); }

return { .. } would work I suppose.

> Source/WebCore/layout/LayoutUnits.h:64
>      void moveBy(LayoutPoint);

Not from this patch but moving a Point by a Point is not good semantically. It would be if you had to explicitly turn Point to Size first. This is how IntPoint etc work.
Comment 4 Antti Koivisto 2019-06-16 12:09:56 PDT
*would be better
Comment 5 Antti Koivisto 2019-06-16 12:14:36 PDT
> > Source/WebCore/layout/LayoutUnits.h:64
> >      void moveBy(LayoutPoint);
> 
> Not from this patch but moving a Point by a Point is not good semantically.
> It would be if you had to explicitly turn Point to Size first. This is how
> IntPoint etc work.

Well, this is not really true. IntPoint makes difference between move and moveBy where later takes an offset point.
Comment 6 zalan 2019-06-16 13:19:29 PDT
Committed r246483: <https://trac.webkit.org/changeset/246483>