Bug 198709 - Make new Symbol/Promise API public
Summary: Make new Symbol/Promise API public
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Keith Miller
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-06-10 02:25 PDT by Keith Miller
Modified: 2019-06-10 09:38 PDT (History)
6 users (show)

See Also:


Attachments
Patch (30.21 KB, patch)
2019-06-10 02:28 PDT, Keith Miller
no flags Details | Formatted Diff | Diff
Patch (31.59 KB, patch)
2019-06-10 02:31 PDT, Keith Miller
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Miller 2019-06-10 02:25:59 PDT
Make new Symbol/Promise API public
Comment 1 Keith Miller 2019-06-10 02:28:14 PDT
Created attachment 371730 [details]
Patch
Comment 2 EWS Watchlist 2019-06-10 02:29:33 PDT
Attachment 371730 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/API/JSValue.h:552:  Misplaced OS version check. Please use a named macro in wtf/Platform.h, wtf/FeatureDefines.h, or an appropriate internal file.  [build/version_check] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:576:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:588:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:601:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:601:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:601:  The parameter name "attributes" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:613:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSValueRef.h:54:  JSC_API_AVAILABLE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/JavaScriptCore/API/JSValueRef.h:152:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/tests/testapi.mm:654:  Misplaced OS version check. Please use a named macro in wtf/Platform.h, wtf/FeatureDefines.h, or an appropriate internal file.  [build/version_check] [5]
Total errors found: 10 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Keith Miller 2019-06-10 02:31:32 PDT
Created attachment 371731 [details]
Patch
Comment 4 EWS Watchlist 2019-06-10 02:34:33 PDT
Attachment 371731 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/API/JSValue.h:552:  Misplaced OS version check. Please use a named macro in wtf/Platform.h, wtf/FeatureDefines.h, or an appropriate internal file.  [build/version_check] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:576:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:588:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:601:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:601:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:601:  The parameter name "attributes" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSObjectRef.h:613:  The parameter name "object" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/JSValueRef.h:54:  JSC_API_AVAILABLE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/JavaScriptCore/API/JSValueRef.h:152:  The parameter name "value" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/API/tests/testapi.mm:654:  Misplaced OS version check. Please use a named macro in wtf/Platform.h, wtf/FeatureDefines.h, or an appropriate internal file.  [build/version_check] [5]
Total errors found: 10 in 7 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Keith Miller 2019-06-10 09:04:37 PDT
Windows build failure seems to be something with generating DerivedSources/JavaScriptCore/CombinedDomains.json. From what I can tell that seems like an inspector thing, which I shouldn't have changed... I guess I'll land this and watch the windows bots.
Comment 6 WebKit Commit Bot 2019-06-10 09:35:06 PDT
Comment on attachment 371731 [details]
Patch

Clearing flags on attachment: 371731

Committed r246265: <https://trac.webkit.org/changeset/246265>
Comment 7 WebKit Commit Bot 2019-06-10 09:35:07 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Radar WebKit Bug Importer 2019-06-10 09:38:58 PDT
<rdar://problem/51584049>