Bug 198559 - "display: contents" Content click does not trigger
Summary: "display: contents" Content click does not trigger
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: Safari 12
Hardware: iPhone / iPad iOS 12
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-06-05 04:14 PDT by 709922234
Modified: 2019-06-13 09:05 PDT (History)
11 users (show)

See Also:


Attachments
Patch (5.77 KB, patch)
2019-06-13 07:21 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description 709922234 2019-06-05 04:14:03 PDT
https://codepen.io/mantou132/pen/gJyBoz

Click on the text in the page, sometimes without triggering the click event
Comment 1 Alexey Proskuryakov 2019-06-06 10:18:41 PDT
I can reproduce on an iPhone with shipping iOS, taps indeed are recognized inconsistently.

Moreover, on an iPad Pro with iOS 13 beta, they are not recognized as clicks at all.
Comment 2 Radar WebKit Bug Importer 2019-06-06 10:18:51 PDT
<rdar://problem/51488524>
Comment 3 Antoine Quint 2019-06-13 06:38:41 PDT
In WebPage::commitPotentialTap() we bail early because m_potentialTapNode->renderer() is false. It might be that we need to also check whether renderOrDisplayContentsStyle() returns something.
Comment 4 Antoine Quint 2019-06-13 07:21:50 PDT
Created attachment 372052 [details]
Patch
Comment 5 WebKit Commit Bot 2019-06-13 09:05:34 PDT
Comment on attachment 372052 [details]
Patch

Clearing flags on attachment: 372052

Committed r246404: <https://trac.webkit.org/changeset/246404>
Comment 6 WebKit Commit Bot 2019-06-13 09:05:35 PDT
All reviewed patches have been landed.  Closing bug.