Bug 198180 - Fix a few missing header inclusions often masked by by unified sources
Summary: Fix a few missing header inclusions often masked by by unified sources
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Adrian Perez
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-05-23 06:48 PDT by Adrian Perez
Modified: 2019-05-23 20:49 PDT (History)
11 users (show)

See Also:


Attachments
Patch (3.70 KB, patch)
2019-05-23 07:34 PDT, Adrian Perez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Perez 2019-05-23 06:48:37 PDT
The following are build errors caused by missing includes which
would have been caught much earlier if unified sources weren't used:

../Source/JavaScriptCore/wasm/WasmBinding.cpp:48:22: error: use of undeclared identifier 'wasmCallingConventionAir'
    GPRReg scratch = wasmCallingConventionAir().prologueScratch(0);
                     ^

../Source/JavaScriptCore/assembler/PerfLog.cpp:147:32: error: implicit instantiation of undefined template 'std::__1::array<char, 1024>'
        std::array<char, 1024> filename;
                               ^

../Source/WebCore/html/FeaturePolicy.cpp:53:58: error: use of undeclared identifier 'isHTMLSpace'
    item = item.stripLeadingAndTrailingMatchedCharacters(isHTMLSpace<UChar>);
                                                         ^

../Source/WebCore/platform/text/TextCodec.cpp:43:16: error: use of undeclared identifier 'snprintf'; did you mean 'vswprintf'?
        return snprintf(replacement.data(), sizeof(UnencodableReplacementArray), "&#%u;", codePoint);
               ^~~~~~~~
               vswprintf
Comment 1 Adrian Perez 2019-05-23 07:34:43 PDT
Created attachment 370505 [details]
Patch
Comment 2 WebKit Commit Bot 2019-05-23 08:47:16 PDT
Comment on attachment 370505 [details]
Patch

Clearing flags on attachment: 370505

Committed r245681: <https://trac.webkit.org/changeset/245681>
Comment 3 WebKit Commit Bot 2019-05-23 08:47:18 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Radar WebKit Bug Importer 2019-05-23 08:48:18 PDT
<rdar://problem/51069221>