Bug 197897 - Fix flakey test fast/events/autoscroll-when-input-is-offscreen.html
Summary: Fix flakey test fast/events/autoscroll-when-input-is-offscreen.html
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Megan Gardner
URL:
Keywords: InRadar
: 197379 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-14 16:02 PDT by Megan Gardner
Modified: 2019-05-15 14:34 PDT (History)
7 users (show)

See Also:


Attachments
Patch (1.70 KB, patch)
2019-05-14 16:03 PDT, Megan Gardner
no flags Details | Formatted Diff | Diff
Patch (1.70 KB, patch)
2019-05-14 16:04 PDT, Megan Gardner
no flags Details | Formatted Diff | Diff
Patch (1.98 KB, patch)
2019-05-14 16:42 PDT, Megan Gardner
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews100 for mac-highsierra (3.21 MB, application/zip)
2019-05-14 17:22 PDT, Build Bot
no flags Details
Patch (2.13 KB, patch)
2019-05-14 17:33 PDT, Megan Gardner
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Megan Gardner 2019-05-14 16:02:07 PDT
Fix flakey test fast/events/autoscroll-when-input-is-offscreen.html
Comment 1 Megan Gardner 2019-05-14 16:03:37 PDT
Created attachment 369904 [details]
Patch
Comment 2 Megan Gardner 2019-05-14 16:04:25 PDT
Created attachment 369905 [details]
Patch
Comment 3 Megan Gardner 2019-05-14 16:04:53 PDT
<rdar://problem/50306931>
Comment 4 Tim Horton 2019-05-14 16:39:02 PDT
Comment on attachment 369905 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=369905&action=review

> LayoutTests/ChangeLog:9
> +        Espeically in debug, scrolling is slow enough that we need to allow for a

"Especially"

> LayoutTests/ChangeLog:10
> +        presentation update. Then we can be sure that the page has finished scrolling

"Scrolling is slow enough" isn't the right phrase. "Programmatic scrolls are included in the transaction and you want to ensure that they've been applied" is better.

> LayoutTests/fast/events/autoscroll-when-input-is-offscreen.html:22
>          var programaticScroll = 500;

Two "m"s in programmatic.
Comment 5 Megan Gardner 2019-05-14 16:42:23 PDT
Created attachment 369908 [details]
Patch
Comment 6 Build Bot 2019-05-14 17:22:46 PDT
Comment on attachment 369908 [details]
Patch

Attachment 369908 [details] did not pass mac-ews (mac):
Output: https://webkit-queues.webkit.org/results/12192748

New failing tests:
fast/events/autoscroll-when-input-is-offscreen.html
Comment 7 Build Bot 2019-05-14 17:22:47 PDT
Created attachment 369911 [details]
Archive of layout-test-results from ews100 for mac-highsierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-highsierra  Platform: Mac OS X 10.13.6
Comment 8 Megan Gardner 2019-05-14 17:33:53 PDT
Created attachment 369912 [details]
Patch
Comment 9 WebKit Commit Bot 2019-05-14 21:00:11 PDT
Comment on attachment 369912 [details]
Patch

Clearing flags on attachment: 369912

Committed r245316: <https://trac.webkit.org/changeset/245316>
Comment 10 WebKit Commit Bot 2019-05-14 21:00:13 PDT
All reviewed patches have been landed.  Closing bug.
Comment 11 Alexey Proskuryakov 2019-05-15 14:34:18 PDT
*** Bug 197379 has been marked as a duplicate of this bug. ***