Bug 197848 - [iOS] Cannot scroll to beginning of document after scrolling to end of document and vice versa via key commands
Summary: [iOS] Cannot scroll to beginning of document after scrolling to end of docume...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Local Build
Hardware: iPhone / iPad iOS 12
: P2 Normal
Assignee: Daniel Bates
URL:
Keywords: InRadar, PlatformOnly
Depends on:
Blocks:
 
Reported: 2019-05-13 12:03 PDT by Daniel Bates
Modified: 2019-05-14 09:43 PDT (History)
5 users (show)

See Also:


Attachments
Patch and layout test (8.30 KB, patch)
2019-05-13 12:30 PDT, Daniel Bates
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bates 2019-05-13 12:03:29 PDT
Seen on iOS using a hardware keyboard.

Steps to reproduce:

1. Visit <https://www.apple.com>.
2. Press Command + Down Arrow.
3. Press Command + Up Arrow.

Then nothing happens, but the page should have been scrolled to the top.
Comment 1 Daniel Bates 2019-05-13 12:03:35 PDT
Following <rdar://problem/49523065>, UIKit does not emit a keyup event for a Command-modified key.
Comment 2 Daniel Bates 2019-05-13 12:03:42 PDT
<rdar://problem/49523065>
Comment 3 Daniel Bates 2019-05-13 12:30:03 PDT
Created attachment 369760 [details]
Patch and layout test
Comment 4 Brent Fulgham 2019-05-14 09:16:15 PDT
Comment on attachment 369760 [details]
Patch and layout test

The api-ios failures are due to dev environment problems. r=me
Comment 5 WebKit Commit Bot 2019-05-14 09:43:57 PDT
Comment on attachment 369760 [details]
Patch and layout test

Clearing flags on attachment: 369760

Committed r245285: <https://trac.webkit.org/changeset/245285>
Comment 6 WebKit Commit Bot 2019-05-14 09:43:59 PDT
All reviewed patches have been landed.  Closing bug.