Bug 197841 - Update TBA macros for API / SPI that has already shipped
Summary: Update TBA macros for API / SPI that has already shipped
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
: 197846 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-13 09:57 PDT by Chris Dumez
Modified: 2019-05-14 11:52 PDT (History)
8 users (show)

See Also:


Attachments
Patch (71.92 KB, patch)
2019-05-13 09:58 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (73.02 KB, patch)
2019-05-13 14:54 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (73.25 KB, patch)
2019-05-13 16:20 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (73.42 KB, patch)
2019-05-14 08:58 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (74.02 KB, patch)
2019-05-14 10:49 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2019-05-13 09:57:09 PDT
Update TBA macros for API / SPI that has already shipped.
Comment 1 Chris Dumez 2019-05-13 09:57:23 PDT
<rdar://problem/50698499>
Comment 2 Chris Dumez 2019-05-13 09:58:19 PDT
Created attachment 369740 [details]
Patch
Comment 3 WebKit Commit Bot 2019-05-13 10:56:30 PDT
Comment on attachment 369740 [details]
Patch

Clearing flags on attachment: 369740

Committed r245240: <https://trac.webkit.org/changeset/245240>
Comment 4 WebKit Commit Bot 2019-05-13 10:56:32 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Chris Dumez 2019-05-13 12:40:06 PDT
Reverted r245240 for reason:

Broke the build

Committed r245245: <https://trac.webkit.org/changeset/245245>
Comment 6 Chris Dumez 2019-05-13 12:40:39 PDT
(In reply to Chris Dumez from comment #5)
> Reverted r245240 for reason:
> 
> Broke the build
> 
> Committed r245245: <https://trac.webkit.org/changeset/245245>

/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:111:17: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:111:84: error: '_internalDebugFeatures' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:112:14: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:118:40: error: '_setEnabled:forInternalDebugFeature:' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/SettingsController.m:226:13: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/SettingsController.m:226:80: error: '_internalDebugFeatures' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/SettingsController.m:228:10: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/SettingsController.m:312:9: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/SettingsController.m:313:50: error: '_isEnabledForInternalDebugFeature:' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/SettingsController.m:652:5: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/SettingsController.m:655:42: error: '_isEnabledForInternalDebugFeature:' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/SettingsController.m:656:18: error: '_setEnabled:forInternalDebugFeature:' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/WK2BrowserWindowController.m:209:37: error: '_inspector' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/WK2BrowserWindowController.m:289:5: error: '_WKInspector' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
/Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/WK2BrowserWindowController.m:289:40: error: '_inspector' is only available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
Comment 7 mitz 2019-05-13 12:44:00 PDT
(In reply to Chris Dumez from comment #6)
> (In reply to Chris Dumez from comment #5)
> > Reverted r245240 for reason:
> > 
> > Broke the build
> > 
> > Committed r245245: <https://trac.webkit.org/changeset/245245>
> 
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:
> 111:17: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4
> or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:
> 111:84: error: '_internalDebugFeatures' is only available on macOS 10.14.4
> or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:
> 112:14: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4
> or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:
> 118:40: error: '_setEnabled:forInternalDebugFeature:' is only available on
> macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> SettingsController.m:226:13: error: '_WKInternalDebugFeature' is only
> available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> SettingsController.m:226:80: error: '_internalDebugFeatures' is only
> available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> SettingsController.m:228:10: error: '_WKInternalDebugFeature' is only
> available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> SettingsController.m:312:9: error: '_WKInternalDebugFeature' is only
> available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> SettingsController.m:313:50: error: '_isEnabledForInternalDebugFeature:' is
> only available on macOS 10.14.4 or newer
> [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> SettingsController.m:652:5: error: '_WKInternalDebugFeature' is only
> available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> SettingsController.m:655:42: error: '_isEnabledForInternalDebugFeature:' is
> only available on macOS 10.14.4 or newer
> [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> SettingsController.m:656:18: error: '_setEnabled:forInternalDebugFeature:'
> is only available on macOS 10.14.4 or newer
> [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> WK2BrowserWindowController.m:209:37: error: '_inspector' is only available
> on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> WK2BrowserWindowController.m:289:5: error: '_WKInspector' is only available
> on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> WK2BrowserWindowController.m:289:40: error: '_inspector' is only available
> on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]

Was this before or after disabling postprocessing for 10.14?
Comment 8 Alexey Proskuryakov 2019-05-13 12:51:55 PDT
Perhaps MiniBrowser needs to disable checking availability annotations? It needs to build and to use trunk features on 10.13.6 anyway, so seems like it has to ignore the annotations.
Comment 9 Chris Dumez 2019-05-13 12:52:33 PDT
(In reply to mitz from comment #7)
> (In reply to Chris Dumez from comment #6)
> > (In reply to Chris Dumez from comment #5)
> > > Reverted r245240 for reason:
> > > 
> > > Broke the build
> > > 
> > > Committed r245245: <https://trac.webkit.org/changeset/245245>
> > 
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:
> > 111:17: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4
> > or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:
> > 111:84: error: '_internalDebugFeatures' is only available on macOS 10.14.4
> > or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:
> > 112:14: error: '_WKInternalDebugFeature' is only available on macOS 10.14.4
> > or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/AppDelegate.m:
> > 118:40: error: '_setEnabled:forInternalDebugFeature:' is only available on
> > macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > SettingsController.m:226:13: error: '_WKInternalDebugFeature' is only
> > available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > SettingsController.m:226:80: error: '_internalDebugFeatures' is only
> > available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > SettingsController.m:228:10: error: '_WKInternalDebugFeature' is only
> > available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > SettingsController.m:312:9: error: '_WKInternalDebugFeature' is only
> > available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > SettingsController.m:313:50: error: '_isEnabledForInternalDebugFeature:' is
> > only available on macOS 10.14.4 or newer
> > [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > SettingsController.m:652:5: error: '_WKInternalDebugFeature' is only
> > available on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > SettingsController.m:655:42: error: '_isEnabledForInternalDebugFeature:' is
> > only available on macOS 10.14.4 or newer
> > [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > SettingsController.m:656:18: error: '_setEnabled:forInternalDebugFeature:'
> > is only available on macOS 10.14.4 or newer
> > [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > WK2BrowserWindowController.m:209:37: error: '_inspector' is only available
> > on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > WK2BrowserWindowController.m:289:5: error: '_WKInspector' is only available
> > on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> > /Volumes/Data/slave/mojave-debug/build/Tools/MiniBrowser/mac/
> > WK2BrowserWindowController.m:289:40: error: '_inspector' is only available
> > on macOS 10.14.4 or newer [-Werror,-Wunguarded-availability-new]
> 
> Was this before or after disabling postprocessing for 10.14?

That was before since my other patch has not landed yet. That said, I am not sure this is the issue because:
1. I have not updated the versions TBA resolve to yet.
2. The SPIs it is complaining about are no longer TBA in my patch.
Comment 10 Chris Dumez 2019-05-13 14:54:46 PDT
Created attachment 369783 [details]
Patch
Comment 11 Chris Dumez 2019-05-13 14:55:00 PDT
*** Bug 197846 has been marked as a duplicate of this bug. ***
Comment 12 Chris Dumez 2019-05-13 14:55:39 PDT
Ok, I merged Bug 197846 into this as it seems we need to land both changes at the same time.
Comment 13 Geoffrey Garen 2019-05-13 15:01:21 PDT
Comment on attachment 369783 [details]
Patch

r=me
Comment 14 Chris Dumez 2019-05-13 16:17:32 PDT
Looks like iOS is unhappy
Comment 15 Chris Dumez 2019-05-13 16:20:06 PDT
Created attachment 369800 [details]
Patch
Comment 16 Chris Dumez 2019-05-13 18:22:52 PDT
Comment on attachment 369800 [details]
Patch

Looks like iOS is still unhappy.
Comment 17 Chris Dumez 2019-05-14 08:41:26 PDT
/Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:73:28: error: expected ';' after method prototype
- (void)_warmInitialProcess WK_API_AVAILABLE(macos(10.12), ios(10.0));
                           ^
                           ;
/Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:74:41: error: expected ';' after method prototype
- (void)_automationCapabilitiesDidChange WK_API_AVAILABLE(macos(10.12), ios(10.0));
                                        ^
                                        ;
/Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:75:89: error: expected ':'
- (void)_setAutomationSession:(_WKAutomationSession *)automationSession WK_API_AVAILABLE(macos(10.12), ios(10.0));
                                                                                        ^
                                                                                        :
/Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:75:89: error: expected ';' after method prototype
- (void)_setAutomationSession:(_WKAutomationSession *)automationSession WK_API_AVAILABLE(macos(10.12), ios(10.0));
                                                                                        ^
                                                                                        ;
/Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:77:185: error: expected ':'
- (void)_addSupportedPlugin:(NSString *) domain named:(NSString *) name withMimeTypes: (NSSet<NSString *> *) mimeTypes withExtensions: (NSSet<NSString *> *) extensions WK_API_AVAILABLE(macos(10.14), ios(12.0));
                                                                                                                                                                                        ^
                                                                                                                                                                                        :
/Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:77:185: error: expected ';' after method prototype
- (void)_addSupportedPlugin:(NSString *) domain named:(NSString *) name withMimeTypes: (NSSet<NSString *> *) mimeTypes withExtensions: (NSSet<NSString *> *) extensions WK_API_AVAILABLE(macos(10.14), ios(12.0));
                                                                                                                                                                                        ^
                                                                   
                                                                                                                     ;
/Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:78:31: error: expected ';' after method prototype
- (void)_clearSupportedPlugins WK_API_AVAILABLE(macos(10.14), ios(12.0));
                              ^
                              ;
fatal error: too many errors emitted, stopping now [-ferror-limit=]
20 errors generated.
Comment 18 Chris Dumez 2019-05-14 08:42:30 PDT
Comment on attachment 369800 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=369800&action=review

> Source/WebKit/Configurations/WebKit.xcconfig:163
> +WK_FRAMEWORK_HEADER_POSTPROCESSING_DISABLED[sdk=iphone*12.*] = YES;

I thought this would take care of the issues on iOS but it did not.
Comment 19 Chris Dumez 2019-05-14 08:58:56 PDT
Created attachment 369856 [details]
Patch
Comment 20 Chris Dumez 2019-05-14 09:00:07 PDT
(In reply to Chris Dumez from comment #17)
> /Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-
> iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:73:28:
> error: expected ';' after method prototype
> - (void)_warmInitialProcess WK_API_AVAILABLE(macos(10.12), ios(10.0));
>                            ^
>                            ;
> /Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-
> iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:74:41:
> error: expected ';' after method prototype
> - (void)_automationCapabilitiesDidChange WK_API_AVAILABLE(macos(10.12),
> ios(10.0));
>                                         ^
>                                         ;
> /Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-
> iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:75:89:
> error: expected ':'
> - (void)_setAutomationSession:(_WKAutomationSession *)automationSession
> WK_API_AVAILABLE(macos(10.12), ios(10.0));
>                                                                             
> ^
>                                                                             
> :
> /Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-
> iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:75:89:
> error: expected ';' after method prototype
> - (void)_setAutomationSession:(_WKAutomationSession *)automationSession
> WK_API_AVAILABLE(macos(10.12), ios(10.0));
>                                                                             
> ^
>                                                                             
> ;
> /Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-
> iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:77:
> 185: error: expected ':'
> - (void)_addSupportedPlugin:(NSString *) domain named:(NSString *) name
> withMimeTypes: (NSSet<NSString *> *) mimeTypes withExtensions:
> (NSSet<NSString *> *) extensions WK_API_AVAILABLE(macos(10.14), ios(12.0));
>                                                                             
> ^
>                                                                             
> :
> /Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-
> iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:77:
> 185: error: expected ';' after method prototype
> - (void)_addSupportedPlugin:(NSString *) domain named:(NSString *) name
> withMimeTypes: (NSSet<NSString *> *) mimeTypes withExtensions:
> (NSSet<NSString *> *) extensions WK_API_AVAILABLE(macos(10.14), ios(12.0));
>                                                                             
> ^
>                                                                    
>                                                                             
> ;
> /Volumes/Data/worker/iOS-12-Simulator-Build-EWS/build/WebKitBuild/Release-
> iphonesimulator/WebKit.framework/PrivateHeaders/WKProcessPoolPrivate.h:78:31:
> error: expected ';' after method prototype
> - (void)_clearSupportedPlugins WK_API_AVAILABLE(macos(10.14), ios(12.0));
>                               ^
>                               ;
> fatal error: too many errors emitted, stopping now [-ferror-limit=]
> 20 errors generated.

Trying to fix this by adding #import <WebKit/WKFoundation.h>
Comment 21 Chris Dumez 2019-05-14 10:28:09 PDT
If anybody has an idea to fix iOS EWS, please let me know. Keith just did a local iOS 12 simulator build with my patch and it built. I have no idea why EWS is having trouble. It looks like it is not finding the WK_API_AVAILABLE define, even though it is supposed to come from WKFoundation.h to be a no-op.
Comment 22 mitz 2019-05-14 10:43:31 PDT
(In reply to Chris Dumez from comment #21)
> If anybody has an idea to fix iOS EWS, please let me know. Keith just did a
> local iOS 12 simulator build with my patch and it built. I have no idea why
> EWS is having trouble. It looks like it is not finding the WK_API_AVAILABLE
> define, even though it is supposed to come from WKFoundation.h to be a no-op.

You may want to force a clean build on the EWS machine (or touch WKFoundation.h in your patch) because otherwise the postprocessed header might not get replaced by the unprocessed one when you disable postprocessing in the xcconfig.
Comment 23 Chris Dumez 2019-05-14 10:49:50 PDT
Created attachment 369868 [details]
Patch
Comment 24 Chris Dumez 2019-05-14 11:25:35 PDT
(In reply to mitz from comment #22)
> (In reply to Chris Dumez from comment #21)
> > If anybody has an idea to fix iOS EWS, please let me know. Keith just did a
> > local iOS 12 simulator build with my patch and it built. I have no idea why
> > EWS is having trouble. It looks like it is not finding the WK_API_AVAILABLE
> > define, even though it is supposed to come from WKFoundation.h to be a no-op.
> 
> You may want to force a clean build on the EWS machine (or touch
> WKFoundation.h in your patch) because otherwise the postprocessed header
> might not get replaced by the unprocessed one when you disable
> postprocessing in the xcconfig.

Yoohoo, it looks like this did the trick. Thanks.
Comment 25 WebKit Commit Bot 2019-05-14 11:52:50 PDT
Comment on attachment 369868 [details]
Patch

Clearing flags on attachment: 369868

Committed r245294: <https://trac.webkit.org/changeset/245294>
Comment 26 WebKit Commit Bot 2019-05-14 11:52:52 PDT
All reviewed patches have been landed.  Closing bug.