Bug 197745 - REGRESSION (r241734): 1% slower PLT on iPad
Summary: REGRESSION (r241734): 1% slower PLT on iPad
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Local Build
Hardware: iPhone / iPad iOS 12
: P2 Normal
Assignee: Daniel Bates
URL:
Keywords: InRadar, PlatformOnly, Regression
Depends on: 192824
Blocks: 190571
  Show dependency treegraph
 
Reported: 2019-05-09 11:15 PDT by Daniel Bates
Modified: 2019-05-09 11:58 PDT (History)
3 users (show)

See Also:


Attachments
Patch (3.22 KB, patch)
2019-05-09 11:42 PDT, Daniel Bates
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bates 2019-05-09 11:15:57 PDT
When building with USE(UIKIT_KEYBOARD_ADDITIONS) enabled and following r241734 we now always request a keyboard when WKContentView becomes first responder as we have one key event handling code path. As it turns out this is expensive enough the cause an ~1% slowdown in PLT on iPad.
Comment 1 Daniel Bates 2019-05-09 11:28:36 PDT
Have a patch that regains the ~1% loss by lazily requesting keyboard instantiation immediately only if we have a hardware keyboard attached. Better fix is to be even lazier: only on first hardware keydown. We'll do this in another bug to spread out the risk and because we (Apple) wants this fix sooner. See bug #197746.
Comment 2 Daniel Bates 2019-05-09 11:41:35 PDT
<rdar://problem/50457731>
Comment 3 Daniel Bates 2019-05-09 11:42:24 PDT
Created attachment 369503 [details]
Patch
Comment 4 Per Arne Vollan 2019-05-09 11:54:51 PDT
Comment on attachment 369503 [details]
Patch

Great work, Dan! R=me.
Comment 5 Daniel Bates 2019-05-09 11:58:48 PDT
Comment on attachment 369503 [details]
Patch

Clearing flags on attachment: 369503

Committed r245148: <https://trac.webkit.org/changeset/245148>
Comment 6 Daniel Bates 2019-05-09 11:58:50 PDT
All reviewed patches have been landed.  Closing bug.