Bug 197692 - Backing-sharing layers with transforms render incorrectly
Summary: Backing-sharing layers with transforms render incorrectly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Compositing (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 197783 (view as bug list)
Depends on:
Blocks: 197561
  Show dependency treegraph
 
Reported: 2019-05-08 09:14 PDT by Simon Fraser (smfr)
Modified: 2019-05-11 17:02 PDT (History)
8 users (show)

See Also:


Attachments
Patch (16.82 KB, patch)
2019-05-09 22:18 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
WIP (23.49 KB, patch)
2019-05-10 10:17 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Patch (38.21 KB, patch)
2019-05-10 22:00 PDT, Simon Fraser (smfr)
koivisto: review+
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews102 for mac-highsierra (3.08 MB, application/zip)
2019-05-10 23:06 PDT, Build Bot
no flags Details
Patch (33.88 KB, patch)
2019-05-10 23:23 PDT, Simon Fraser (smfr)
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews115 for mac-highsierra (2.86 MB, application/zip)
2019-05-10 23:51 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews125 for ios-simulator-wk2 (2.53 MB, application/zip)
2019-05-11 00:01 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews103 for mac-highsierra (3.10 MB, application/zip)
2019-05-11 00:29 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews107 for mac-highsierra-wk2 (2.65 MB, application/zip)
2019-05-11 00:43 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews215 for win-future (13.55 MB, application/zip)
2019-05-11 01:06 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews114 for mac-highsierra (2.92 MB, application/zip)
2019-05-11 01:20 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews124 for ios-simulator-wk2 (8.45 MB, application/zip)
2019-05-11 01:26 PDT, Build Bot
no flags Details
Patch (31.58 KB, patch)
2019-05-11 08:18 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2019-05-08 09:14:25 PDT
If a layer gets backing-shared that has a transform, the rendering is incorrect.

Affects http://www.deeplearningbook.org/contents/intro.html
Comment 1 Radar WebKit Bug Importer 2019-05-09 22:15:22 PDT
<rdar://problem/50652127>
Comment 2 Simon Fraser (smfr) 2019-05-09 22:18:52 PDT
Created attachment 369544 [details]
Patch
Comment 3 Simon Fraser (smfr) 2019-05-10 10:17:20 PDT
Created attachment 369561 [details]
WIP
Comment 4 Simon Fraser (smfr) 2019-05-10 22:00:48 PDT
Created attachment 369637 [details]
Patch
Comment 5 Antti Koivisto 2019-05-10 22:16:38 PDT
Comment on attachment 369637 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=369637&action=review

> LayoutTests/compositing/shared-backing/shared-layer-has-transform-expected.html:31
> +        .trigger {
> +            transform: translateZ(0);

I imagine we might optimimize this case some day to not composite so this might not be the safest trigger.
Comment 6 Simon Fraser (smfr) 2019-05-10 22:36:03 PDT
(In reply to Antti Koivisto from comment #5)
> Comment on attachment 369637 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=369637&action=review
> 
> > LayoutTests/compositing/shared-backing/shared-layer-has-transform-expected.html:31
> > +        .trigger {
> > +            transform: translateZ(0);
> 
> I imagine we might optimimize this case some day to not composite so this
> might not be the safest trigger.

When that happens we'll have to change a lot of tests :)
Comment 7 Build Bot 2019-05-10 23:06:01 PDT Comment hidden (obsolete)
Comment 8 Build Bot 2019-05-10 23:06:04 PDT Comment hidden (obsolete)
Comment 9 Simon Fraser (smfr) 2019-05-10 23:18:56 PDT
Added a couple of test files by mistake. Why is mac-wk2 green?
Comment 10 Simon Fraser (smfr) 2019-05-10 23:23:55 PDT
Created attachment 369639 [details]
Patch
Comment 11 Build Bot 2019-05-10 23:51:54 PDT Comment hidden (obsolete)
Comment 12 Build Bot 2019-05-10 23:51:56 PDT Comment hidden (obsolete)
Comment 13 Build Bot 2019-05-11 00:01:00 PDT Comment hidden (obsolete)
Comment 14 Build Bot 2019-05-11 00:01:02 PDT Comment hidden (obsolete)
Comment 15 Build Bot 2019-05-11 00:29:19 PDT Comment hidden (obsolete)
Comment 16 Build Bot 2019-05-11 00:29:21 PDT Comment hidden (obsolete)
Comment 17 Build Bot 2019-05-11 00:43:23 PDT Comment hidden (obsolete)
Comment 18 Build Bot 2019-05-11 00:43:24 PDT Comment hidden (obsolete)
Comment 19 Build Bot 2019-05-11 01:06:43 PDT Comment hidden (obsolete)
Comment 20 Build Bot 2019-05-11 01:06:46 PDT Comment hidden (obsolete)
Comment 21 Build Bot 2019-05-11 01:20:53 PDT Comment hidden (obsolete)
Comment 22 Build Bot 2019-05-11 01:20:55 PDT Comment hidden (obsolete)
Comment 23 Build Bot 2019-05-11 01:26:57 PDT Comment hidden (obsolete)
Comment 24 Build Bot 2019-05-11 01:26:59 PDT Comment hidden (obsolete)
Comment 25 Simon Fraser (smfr) 2019-05-11 08:18:25 PDT
Created attachment 369652 [details]
Patch
Comment 26 Simon Fraser (smfr) 2019-05-11 10:21:22 PDT
*** Bug 197783 has been marked as a duplicate of this bug. ***
Comment 27 WebKit Commit Bot 2019-05-11 10:35:36 PDT
Comment on attachment 369652 [details]
Patch

Clearing flags on attachment: 369652

Committed r245205: <https://trac.webkit.org/changeset/245205>