Bug 19769 - [Qt] Dotted lines are affected by container's style
Summary: [Qt] Dotted lines are affected by container's style
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2008-06-25 09:38 PDT by Pierre-Luc Beaudoin
Modified: 2009-12-01 08:43 PST (History)
1 user (show)

See Also:


Attachments
Example of the issue (687 bytes, text/html)
2008-06-25 09:40 PDT, Pierre-Luc Beaudoin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre-Luc Beaudoin 2008-06-25 09:38:06 PDT
If you place a dotted underlined link inside a div which has a solid border, the dots under the line will be different than if there were no border on the div.

I'll attach a example.
Comment 1 Pierre-Luc Beaudoin 2008-06-25 09:40:46 PDT
Created attachment 21933 [details]
Example of the issue

This is the most simple case where you can reproduce the issue.  The top link has strange dots as the bottom link is correctly rendered.

The results change a lot if Anti-aliasing is forced on lines (the first link will get a mostly black underline).
Comment 2 Jocelyn Turcotte 2009-12-01 08:43:42 PST
I am not able to reproduce this problem in 4.5.3 or 4.6.0

This is an old bug and I will resolve it guessing that it was fixed.
Please re-open if i'm wrong.