Bug 197442 - REGRESSION (r242741) [Mac WK1 Debug] Layout Test inspector/timeline/exception-in-injected-script-while-recording.html is a flaky crash
Summary: REGRESSION (r242741) [Mac WK1 Debug] Layout Test inspector/timeline/exception...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-30 16:07 PDT by Shawn Roberts
Modified: 2019-05-15 15:36 PDT (History)
9 users (show)

See Also:


Attachments
Patch (11.93 KB, patch)
2019-05-13 00:18 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Roberts 2019-04-30 16:07:10 PDT
The following layout test is flaky on Mac WK1 Debug

inspector/heap/tracking.html

Probable cause:

Test has been crashing it's entire available history on the dashboard. Local testing verified that the test started crashing in https://trac.webkit.org/changeset/242741/webkit and passed in prior revisions. 

Reproduced with:

run-webkit-tests inspector/timeline/exception-in-injected-script-while-recording.html --iterations 1000 -f --debug -1 --exit-after-n-crashes=1

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=inspector%2Fheap%2Ftracking.html

Crash Log:

Thread 7 Crashed:: WebCore: ResourceUsage
0   com.apple.JavaScriptCore      	0x000000010e01bff0 WTFCrash + 16 (Assertions.cpp:305)
1   com.apple.WebCore             	0x000000011b461a8b WTFCrashWithInfo(int, char const*, char const*, int) + 27
2   com.apple.WebCore             	0x000000011b9689f3 WebCore::threadInfos() + 483 (ResourceUsageThreadCocoa.mm:195)
3   com.apple.WebCore             	0x000000011b967ce2 WebCore::ResourceUsageThread::platformCollectCPUData(JSC::VM*, WebCore::ResourceUsageData&) + 82 (ResourceUsageThreadCocoa.mm:244)

https://build.webkit.org/results/Apple%20High%20Sierra%20Debug%20WK1%20(Tests)/r244750%20(8923)/inspector/timeline/exception-in-injected-script-while-recording-crash-log.txt
Comment 1 Radar WebKit Bug Importer 2019-04-30 16:08:11 PDT
<rdar://problem/50354090>
Comment 2 Shawn Roberts 2019-04-30 16:09:23 PDT
inspector/timeline/exception-in-injected-script-while-recording.html is crashing.

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=inspector%2Ftimeline%2Fexception-in-injected-script-while-recording.html

NOT inspector/heap/tracking.html
Comment 3 Devin Rousso 2019-05-13 00:18:43 PDT
Created attachment 369702 [details]
Patch
Comment 4 Alexey Proskuryakov 2019-05-13 13:52:55 PDT
Comment on attachment 369702 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=369702&action=review

> LayoutTests/ChangeLog:10
> +        Ever since r198774, we don't allow a timeline recording to be active at the same time as the
> +        debugger being paused. As such, these tests are unnecessary.

Oh wow.

> LayoutTests/TestExpectations:-536
> -webkit.org/b/142208 inspector/timeline/debugger-paused-while-recording.html [ Skip ]
> -webkit.org/b/142208 inspector/timeline/exception-in-injected-script-while-recording.html [ Skip ]

So these didn't work because platform specific files acted as overrides:

LayoutTests/platform/mac-wk1/TestExpectations:704:webkit.org/b/196915 [ Debug ] inspector/timeline/timeline-recording.html [ Pass Failure ]
LayoutTests/platform/mac/TestExpectations:1095:webkit.org/b/158948 inspector/timeline [ Pass Timeout ]
Comment 5 Joseph Pecoraro 2019-05-15 15:08:29 PDT
Comment on attachment 369702 [details]
Patch

rs=me
Comment 6 WebKit Commit Bot 2019-05-15 15:36:40 PDT
Comment on attachment 369702 [details]
Patch

Clearing flags on attachment: 369702

Committed r245362: <https://trac.webkit.org/changeset/245362>
Comment 7 WebKit Commit Bot 2019-05-15 15:36:41 PDT
All reviewed patches have been landed.  Closing bug.