Bug 19741 - Changing an SVGPathSeg does not update a following Smooth Cubic Curveto
Summary: Changing an SVGPathSeg does not update a following Smooth Cubic Curveto
Status: RESOLVED DUPLICATE of bug 49580
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 10827
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-24 02:38 PDT by Audun Wilhelmsen
Modified: 2010-11-17 06:35 PST (History)
2 users (show)

See Also:


Attachments
A testcase (1.30 KB, image/svg+xml)
2008-06-24 02:40 PDT, Audun Wilhelmsen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Audun Wilhelmsen 2008-06-24 02:38:04 PDT
Changing the coordinates of a path segment does not update the automatic control point for the next smooth cubic curveto segment.
Comment 1 Audun Wilhelmsen 2008-06-24 02:40:53 PDT
Created attachment 21900 [details]
A testcase

We have a path with a move to and a smooth curveto segment.  The move to is moved by a timed javascript, showing that the automatic control point for the smooth curveto segment is not updated.
Comment 2 Eric Seidel (no email) 2008-07-03 22:02:25 PDT
Our behavior is not identical to FF.  I can't get Opera to launch on my machine... :(  From the test case it's not very easy to tell if something is wrong or not... but I do think we might have an issue here.  A better test case would make it very clear if the behavior is correct or not (by showing only green on pass and red on fail, or showing some pass/fail text, etc.)
Comment 3 Rob Buis 2008-07-05 12:29:15 PDT
(In reply to comment #2)
> Our behavior is not identical to FF.  I can't get Opera to launch on my
> machine... :(  From the test case it's not very easy to tell if something is
> wrong or not... but I do think we might have an issue here.  A better test case
> would make it very clear if the behavior is correct or not (by showing only
> green on pass and red on fail, or showing some pass/fail text, etc.)

Opera behaves the same as FF here.
The problem is that we expose only moveto, lineto and cubic curveto in this interface, not the smooth one. Likely the right fix would be to do expose them
(lazily), and internally use some quick format. I wonder if there already is a bug for this...
Cheers,

Rob.
Comment 4 Rob Buis 2008-07-05 12:33:10 PDT
Ok, a bug that is slightly related that I was hinting at is bug 10827. I am having a look at fixing that as it should solve this problem AFAICS.
Cheers,

Rob.
Comment 5 Nikolas Zimmermann 2010-11-17 06:35:55 PST

*** This bug has been marked as a duplicate of bug 49580 ***