Bug 19740 - Using a framework such as Sparkle to make the nightly builds self-updating.
Summary: Using a framework such as Sparkle to make the nightly builds self-updating.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Enhancement
Assignee: Nobody
URL: http://sparkle.andymatuschak.org/
Keywords:
: 20861 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-24 01:51 PDT by Trevor Downs
Modified: 2009-01-14 04:43 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trevor Downs 2008-06-24 01:51:06 PDT
Using a framework such as Sparkle <http://sparkle.andymatuschak.org/> (Mac OS X-only) I'd like to see WebKit nightly builds be able to fetch and install new versions of themselves automatically.
Comment 1 Mark Rowe (bdash) 2008-06-24 13:23:40 PDT
The nightly build launcher simply runs Safari, so there is no real opportunity to run any code to check for updates on an ongoing basis when the nightly build is running.  Checking on launch inside the launcher application itself would lead to a long delay before Safari appeared, which also does not seem like a good idea.  I think this is a task better suited to an external application.
Comment 2 Mark Rowe (bdash) 2008-09-15 15:15:43 PDT
*** Bug 20861 has been marked as a duplicate of this bug. ***
Comment 3 Jordi Bunster 2008-09-15 15:21:35 PDT
Is it not possible to spawn a thread upon the start of the launcher app, and check for updates after a timeout?

That way, it doesn't delay Safari from starting.
Comment 4 Mark Rowe (bdash) 2008-09-15 15:36:08 PDT
Starting Safari involves calling "exec", so the process that was running no longer exists.
Comment 5 opendarwin 2008-09-15 19:25:23 PDT
NightShift <http://web.mac.com/reinholdpenner/Software/NightShift.html> might be a good solution for this. (Note: I haven't tried it myself, so this is not an endorsement, just a suggestion.)

Comment 6 David Smith 2009-01-14 04:43:18 PST
Since this has been fixed, resolved wontfix seems inappropriate now ;)