Bug 197308 - [Cairo] Improve ShadowBlur performance using tiling optimization
Summary: [Cairo] Improve ShadowBlur performance using tiling optimization
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Windows 10
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-25 23:20 PDT by Tomoki Imai
Modified: 2019-05-03 11:32 PDT (History)
8 users (show)

See Also:


Attachments
Patch (51.21 KB, patch)
2019-04-25 23:24 PDT, Tomoki Imai
no flags Details | Formatted Diff | Diff
Patch (51.20 KB, patch)
2019-04-26 00:20 PDT, Tomoki Imai
no flags Details | Formatted Diff | Diff
Outer shadow benchmark (642 bytes, text/html)
2019-04-26 00:32 PDT, Tomoki Imai
no flags Details
Inner shadow benchmark (647 bytes, text/html)
2019-04-26 00:33 PDT, Tomoki Imai
no flags Details
Archive of layout-test-results from ews122 for ios-simulator-wk2 (2.70 MB, application/zip)
2019-04-26 02:18 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomoki Imai 2019-04-25 23:20:23 PDT
We want to enable tiling tiling-based optimization for drawRectShadow() and drawInsetShadow().
Since r228776, cairo ports doesn't have tiling-based optimization, we see some performance regressions.
Comment 1 Tomoki Imai 2019-04-25 23:24:15 PDT
Created attachment 368306 [details]
Patch

Patch
Comment 2 Tomoki Imai 2019-04-26 00:20:36 PDT
Created attachment 368307 [details]
Patch

Try to Fix Mac build
Comment 3 Tomoki Imai 2019-04-26 00:32:29 PDT
Created attachment 368308 [details]
Outer shadow benchmark

Simple outer shadowblur benchmark
Comment 4 Tomoki Imai 2019-04-26 00:33:10 PDT
Created attachment 368309 [details]
Inner shadow benchmark

Inset shadow benchmark
Comment 5 Tomoki Imai 2019-04-26 00:38:27 PDT
I ran LayoutTests for WinCairo and GTK, and didn't see any regression cases.
Comment 6 Build Bot 2019-04-26 02:18:31 PDT
Comment on attachment 368307 [details]
Patch

Attachment 368307 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: https://webkit-queues.webkit.org/results/12003413

New failing tests:
imported/w3c/web-platform-tests/service-workers/cache-storage/window/cache-abort.https.html
Comment 7 Build Bot 2019-04-26 02:18:32 PDT
Created attachment 368312 [details]
Archive of layout-test-results from ews122 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews122  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.6
Comment 8 WebKit Commit Bot 2019-05-03 11:31:11 PDT
Comment on attachment 368307 [details]
Patch

Clearing flags on attachment: 368307

Committed r244913: <https://trac.webkit.org/changeset/244913>
Comment 9 WebKit Commit Bot 2019-05-03 11:31:13 PDT
All reviewed patches have been landed.  Closing bug.
Comment 10 Radar WebKit Bug Importer 2019-05-03 11:32:45 PDT
<rdar://problem/50450914>