Smarter code uses smart pointers :) (Sounded better in my head) and why not rename +autocorrectionRectsWithRects to autocorrectionRectsWithCGRects to make it clear what kinds of rects we expect: CGRects of course!
I still don't like the name.... +autocorrectionRectsWithCGRects... hmm.
Created attachment 367841 [details]
Went with +autocorrectionRectsWithFirstCGRect:lastCGRect:. It is a bit more verbose than I would like. I would need to understand the purpose of these rects to have a chance at a coming up with a better name I think.
Comment on attachment 367841 [details]
Clearing flags on attachment: 367841
Committed r244474: <https://trac.webkit.org/changeset/244474>
All reviewed patches have been landed. Closing bug.