Bug 196946 - CSS background-color transition flickers
Summary: CSS background-color transition flickers
Status: RESOLVED DUPLICATE of bug 197654
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Safari 12
Hardware: Macintosh macOS 10.14
: P2 Normal
Assignee: Nobody
URL: https://reprod-safari-bug-ekufemrdfl....
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-15 16:03 PDT by Ben Nyberg
Modified: 2019-06-01 19:54 PDT (History)
3 users (show)

See Also:


Attachments
Gif of what I am seeing on my machine (243.99 KB, image/gif)
2019-04-15 16:03 PDT, Ben Nyberg
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Nyberg 2019-04-15 16:03:57 PDT
Created attachment 367470 [details]
Gif of what I am seeing on my machine

Please take a look at the following page: https://reprod-safari-bug-ekufemrdfl.now.sh

Every second, a class is toggled that is intended to toggle the background-color and color properties of the #site-mast element.

In the current version of Safari, the background-color flickers. Removing the background-color CSS transition seems to fix this.

Please let me know if you need any more info, or if I can provide any more details.
Comment 1 Radar WebKit Bug Importer 2019-04-15 18:21:26 PDT
<rdar://problem/49926199>
Comment 2 Simon Fraser (smfr) 2019-04-15 21:20:04 PDT
Looks like we're failing to mark the layer as non-opaque when the background-color changes from something opaque to something non-opaque.
Comment 3 Simon Fraser (smfr) 2019-06-01 19:54:50 PDT
Fixed by 197654.

*** This bug has been marked as a duplicate of bug 197654 ***