Bug 196820 - [iOS WK2] Handle more variations of positioned elements inside async overflow scroll
Summary: [iOS WK2] Handle more variations of positioned elements inside async overflow...
Status: RESOLVED DUPLICATE of bug 196146
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-11 08:52 PDT by Simon Fraser (smfr)
Modified: 2019-04-11 22:38 PDT (History)
3 users (show)

See Also:


Attachments
Patch (29.26 KB, patch)
2019-04-11 09:04 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews102 for mac-highsierra (2.48 MB, application/zip)
2019-04-11 10:08 PDT, EWS Watchlist
no flags Details
Archive of layout-test-results from ews107 for mac-highsierra-wk2 (2.80 MB, application/zip)
2019-04-11 10:21 PDT, EWS Watchlist
no flags Details
Archive of layout-test-results from ews112 for mac-highsierra (2.32 MB, application/zip)
2019-04-11 10:51 PDT, EWS Watchlist
no flags Details
Archive of layout-test-results from ews122 for ios-simulator-wk2 (2.77 MB, application/zip)
2019-04-11 11:00 PDT, EWS Watchlist
no flags Details
Patch (37.42 KB, patch)
2019-04-11 18:32 PDT, Simon Fraser (smfr)
ews-watchlist: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews122 for ios-simulator-wk2 (2.61 MB, application/zip)
2019-04-11 20:27 PDT, EWS Watchlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2019-04-11 08:52:06 PDT
[iOS WK2] Handle more variations of positioned elements inside async overflow scroll
Comment 1 Simon Fraser (smfr) 2019-04-11 09:04:41 PDT
Created attachment 367220 [details]
Patch
Comment 2 EWS Watchlist 2019-04-11 10:08:13 PDT
Comment on attachment 367220 [details]
Patch

Attachment 367220 [details] did not pass mac-ews (mac):
Output: https://webkit-queues.webkit.org/results/11841686

New failing tests:
fast/css/will-change/will-change-creates-stacking-context-inline.html
Comment 3 EWS Watchlist 2019-04-11 10:08:14 PDT
Created attachment 367224 [details]
Archive of layout-test-results from ews102 for mac-highsierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews102  Port: mac-highsierra  Platform: Mac OS X 10.13.6
Comment 4 EWS Watchlist 2019-04-11 10:21:13 PDT
Comment on attachment 367220 [details]
Patch

Attachment 367220 [details] did not pass mac-wk2-ews (mac-wk2):
Output: https://webkit-queues.webkit.org/results/11841721

New failing tests:
scrollingcoordinator/scrolling-tree/nested-absolute-in-absolute-overflow.html
scrollingcoordinator/scrolling-tree/nested-absolute-in-overflow.html
scrollingcoordinator/scrolling-tree/positioned-nodes-complex.html
fast/css/will-change/will-change-creates-stacking-context-inline.html
scrollingcoordinator/scrolling-tree/nested-absolute-in-relative-in-overflow.html
scrollingcoordinator/scrolling-tree/nested-absolute-in-sc-overflow.html
Comment 5 EWS Watchlist 2019-04-11 10:21:15 PDT
Created attachment 367225 [details]
Archive of layout-test-results from ews107 for mac-highsierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-highsierra-wk2  Platform: Mac OS X 10.13.6
Comment 6 EWS Watchlist 2019-04-11 10:51:23 PDT
Comment on attachment 367220 [details]
Patch

Attachment 367220 [details] did not pass mac-debug-ews (mac):
Output: https://webkit-queues.webkit.org/results/11841791

New failing tests:
fast/css/will-change/will-change-creates-stacking-context-inline.html
Comment 7 EWS Watchlist 2019-04-11 10:51:25 PDT
Created attachment 367227 [details]
Archive of layout-test-results from ews112 for mac-highsierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews112  Port: mac-highsierra  Platform: Mac OS X 10.13.6
Comment 8 EWS Watchlist 2019-04-11 11:00:03 PDT
Comment on attachment 367220 [details]
Patch

Attachment 367220 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: https://webkit-queues.webkit.org/results/11841861

New failing tests:
fast/scrolling/ios/overflow-scroll-overlap-6.html
fast/css/will-change/will-change-creates-stacking-context-inline.html
scrollingcoordinator/scrolling-tree/positioned-nodes-complex.html
fast/scrolling/ios/change-scrollability-on-content-resize.html
Comment 9 EWS Watchlist 2019-04-11 11:00:05 PDT
Created attachment 367228 [details]
Archive of layout-test-results from ews122 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews122  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.6
Comment 10 Simon Fraser (smfr) 2019-04-11 18:32:03 PDT
Created attachment 367275 [details]
Patch
Comment 11 EWS Watchlist 2019-04-11 20:27:39 PDT
Comment on attachment 367275 [details]
Patch

Attachment 367275 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: https://webkit-queues.webkit.org/results/11848934

New failing tests:
fast/scrolling/ios/overflow-scroll-overlap-6.html
Comment 12 EWS Watchlist 2019-04-11 20:27:41 PDT
Created attachment 367280 [details]
Archive of layout-test-results from ews122 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews122  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.6
Comment 13 Simon Fraser (smfr) 2019-04-11 22:38:20 PDT
Fixing this via bug 196146.

*** This bug has been marked as a duplicate of bug 196146 ***