Bug 19670 - Persistently broken acid2 rendering after zooming out twice
Summary: Persistently broken acid2 rendering after zooming out twice
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://acid2.acidtests.org/#top
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-19 02:40 PDT by Alex Stapleton
Modified: 2008-07-17 00:03 PDT (History)
3 users (show)

See Also:


Attachments
Example of broken acid2 rendering after zooming out and back in again (65.79 KB, image/png)
2008-06-19 02:40 PDT, Alex Stapleton
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Stapleton 2008-06-19 02:40:07 PDT
These are the steps i've been using. Probably reproducible using the mouse as well? Let the page render after each step.

Load acid2 and let it render.

Press command-minus twice to zoom out

Reload the page using command-r

Press command-0 to zoom back to normal

Reload the page using command-r

Now no longer renders correctly and is persistently broken over reloads. I've had it fail in 2 different ways so far. Not entirely sure what the difference between the 2 failure modes was.
Comment 1 Alex Stapleton 2008-06-19 02:40:36 PDT
Created attachment 21835 [details]
Example of broken acid2 rendering after zooming out and back in again
Comment 2 Alexey Proskuryakov 2008-06-19 18:00:44 PDT
As far as I understand, the going directly to #top is not a correct way to run Acid2. The persistent change in rendering certainly does look wrong, but I'm still not quite sure if it's a bug.
Comment 3 Robert Blaut 2008-07-17 00:03:31 PDT
"Note: When taking the test, you should use the default settings of the browser you are testing. Changing the zoom level, minimum font size, applying a fit-to-width algorithm, or making other changes may alter the rendition of the Acid2 page without this constituting a failure in compliance." [http://www.webstandards.org/action/acid2/guide/]

The test always should be performed by going to http://acid2.acidtests.org/ first and clicking "Take the Acid 2 test". It's important for proper calculation of position: fixed "hat".

I close the bug report since the described issue is not  a bug.