Bug 196607 - [ews-app] status-bubble should display position in queue
Summary: [ews-app] status-bubble should display position in queue
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Aakash Jain
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-04 08:59 PDT by Aakash Jain
Modified: 2019-04-15 13:19 PDT (History)
5 users (show)

See Also:


Attachments
WIP (3.24 KB, patch)
2019-04-10 13:51 PDT, Aakash Jain
no flags Details | Formatted Diff | Diff
Proposed patch (3.69 KB, patch)
2019-04-13 05:58 PDT, Aakash Jain
lforschler: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aakash Jain 2019-04-04 08:59:41 PDT
While a patch is waiting in queue, ews-app's status-bubble should display its position in queue.
Comment 1 Aakash Jain 2019-04-10 13:51:51 PDT
Created attachment 367158 [details]
WIP
Comment 2 Kocsen Chung 2019-04-12 10:51:17 PDT
Comment on attachment 367158 [details]
WIP

View in context: https://bugs.webkit.org/attachment.cgi?id=367158&action=review

> Tools/BuildSlaveSupport/ews-app/ews/views/statusbubble.py:64
> +            bubble["queue_position"] = queue_position

nit: inconsistent use of `"` and `'`. Seems like most of it is `'` so we can stick to that.

> Tools/BuildSlaveSupport/ews-app/ews/views/statusbubble.py:178
> +        previously_sent_patches = set(Patch.objects.filter(modified__gte=from_timestamp).filter(sent_to_buildbot=True).filter(obsolete=False).filter(modified__lt=patch.modified))

nit: I think it would be more readable if the filters are above one another.

```python
Patch.objects
    .filter(x)
    .filter(y)
[...]
```
Comment 3 Aakash Jain 2019-04-13 05:58:47 PDT
Created attachment 367386 [details]
Proposed patch

Incorporated review comments.
Comment 4 Lucas Forschler 2019-04-15 13:04:59 PDT
Comment on attachment 367386 [details]
Proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=367386&action=review

> Tools/BuildSlaveSupport/ews-app/ews/views/statusbubble.py:194
> +        processed_patch = set([build.patch for build in recent_builds])

should this be "processed_patches" ?
Comment 5 Aakash Jain 2019-04-15 13:18:38 PDT
> should this be "processed_patches" ?
Yes, changed.
Comment 6 Aakash Jain 2019-04-15 13:18:51 PDT
Committed r244284: <https://trac.webkit.org/changeset/244284>
Comment 7 Radar WebKit Bug Importer 2019-04-15 13:19:26 PDT
<rdar://problem/49914755>