Bug 196448 - [ Mac Debug ] Layout Test inspector/audit/basic.html is a flaky timeout on bots
Summary: [ Mac Debug ] Layout Test inspector/audit/basic.html is a flaky timeout on bots
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-04-01 10:56 PDT by Shawn Roberts
Modified: 2019-05-13 15:17 PDT (History)
8 users (show)

See Also:


Attachments
Patch (32.90 KB, patch)
2019-05-12 23:30 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Roberts 2019-04-01 10:56:44 PDT
The following layout test is flaky on Mac Debug

inspector/audit/basic.html

Probable cause:

Test was added in https://trac.webkit.org/changeset/237613/webkit , changed in https://trac.webkit.org/changeset/238850/webkit and https://trac.webkit.org/changeset/239646/webkit

Unable to reproduce locally with 1000 iterations in Mojave Debug WK2 or WK1. However it's a flaky time out in its entire available dashboard history, and appears to be timing out more frequently on Mojave Debug WK2, nearly one in every 3 runs starting around 3/23/19.

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=inspector%2Faudit%2Fbasic.html
Comment 1 Radar WebKit Bug Importer 2019-04-01 10:57:18 PDT
<rdar://problem/49485452>
Comment 2 Shawn Roberts 2019-04-02 09:23:49 PDT
Marked flaky in https://trac.webkit.org/changeset/243745/webkit while waiting for a fix.
Comment 3 Devin Rousso 2019-05-12 23:30:00 PDT
Created attachment 369698 [details]
Patch
Comment 4 Devin Rousso 2019-05-12 23:31:06 PDT
Comment on attachment 369698 [details]
Patch

I'm not actually sure if this works (e.g. stops timing out), but I think that the underlying issue only affects a specific part of the test.  Splitting it into separate tests will either resolve the problem (in the case that it was just too long) or will allow me to understand which specific part is the issue.
Comment 5 WebKit Commit Bot 2019-05-13 15:17:01 PDT
Comment on attachment 369698 [details]
Patch

Clearing flags on attachment: 369698

Committed r245257: <https://trac.webkit.org/changeset/245257>
Comment 6 WebKit Commit Bot 2019-05-13 15:17:03 PDT
All reviewed patches have been landed.  Closing bug.