Bug 196408 - [ContentChangeObserver] Subframe load should not reset content observation on the mainframe
Summary: [ContentChangeObserver] Subframe load should not reset content observation on...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-03-29 15:08 PDT by zalan
Modified: 2019-03-30 06:47 PDT (History)
5 users (show)

See Also:


Attachments
Patch (5.29 KB, text/plain)
2019-03-29 15:23 PDT, zalan
no flags Details
Patch (5.35 KB, patch)
2019-03-29 16:07 PDT, zalan
simon.fraser: review+
ews-watchlist: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews114 for mac-highsierra (2.46 MB, application/zip)
2019-03-29 18:02 PDT, EWS Watchlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description zalan 2019-03-29 15:08:31 PDT
ssia
Comment 1 Radar WebKit Bug Importer 2019-03-29 15:11:14 PDT
<rdar://problem/49436797>
Comment 2 zalan 2019-03-29 15:23:24 PDT
Created attachment 366312 [details]
Patch
Comment 3 zalan 2019-03-29 16:07:07 PDT
Created attachment 366318 [details]
Patch
Comment 4 EWS Watchlist 2019-03-29 18:02:29 PDT
Comment on attachment 366318 [details]
Patch

Attachment 366318 [details] did not pass mac-debug-ews (mac):
Output: https://webkit-queues.webkit.org/results/11707786

New failing tests:
jquery/offset.html
Comment 5 EWS Watchlist 2019-03-29 18:02:31 PDT
Created attachment 366337 [details]
Archive of layout-test-results from ews114 for mac-highsierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews114  Port: mac-highsierra  Platform: Mac OS X 10.13.6
Comment 6 zalan 2019-03-30 06:47:47 PDT
Committed r243677: <https://trac.webkit.org/changeset/243677>