Bug 19634 - Display:none style of <legend> is ignored if <legend> is inside a <form> tag
Summary: Display:none style of <legend> is ignored if <legend> is inside a <form> tag
Status: RESOLVED DUPLICATE of bug 18691
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-17 17:04 PDT by Anantha Keesara
Modified: 2008-07-16 02:34 PDT (History)
2 users (show)

See Also:


Attachments
reduction (448 bytes, text/html)
2008-06-17 17:24 PDT, Anantha Keesara
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anantha Keesara 2008-06-17 17:04:05 PDT
I. Steps:
 -----------
 
 1. Launch Safari
 2. Launch the attached testcase
 
 
 II. Issue:
 -----------------
 The <legend> has display:none but Safari still displays it because it's inside a <form> tag. 
 
 
 
 III. Other browsers:
 -----------------------
 IE7 : ok
 FF3 : ok
 Opera 9.27: Ok
 
 
 IV. Safari nightly tested: version 3.1.1(525.17 )- r34278.
 
 Not working properly on Safari.
 
 
 
 V. Safari screenshot : Not Avalible
Comment 1 Mark Rowe (bdash) 2008-06-17 17:22:29 PDT
There is no attached test case.  The summary of this bug does not describe the issue at all.

If you're going to file bug reports, please pick a *useful* summary and include a test case or steps to reproduce.
Comment 2 Anantha Keesara 2008-06-17 17:24:39 PDT
Created attachment 21801 [details]
reduction
Comment 3 Mark Rowe (bdash) 2008-06-17 17:37:37 PDT
.
Comment 4 mitz 2008-06-17 17:52:54 PDT
There is actually no legend element in the DOM, and the text node got is right under the form element.
Comment 5 Robert Blaut 2008-07-16 02:34:55 PDT
(In reply to comment #4)
> There is actually no legend element in the DOM, and the text node got is right
> under the form element.
> 

So it is the reason why style is ignored for this legend element. Ignoring legend element outside a fieldset element issue is already known and tracked by bug 18691. Closing as duplicate.

*** This bug has been marked as a duplicate of 18691 ***